[BUG] Metal Gear final stairs

Page 1/6
| 2 | 3 | 4 | 5 | 6

By Rataplan

Master (161)

Rataplan's picture

15-05-2006, 13:22

Hi peops,
I was finishing Metal Gear once again last week, wanting to finish it atleast once in every MSX2 emu I have. Last week it was fMSXSO's turn. I used latest version, with Panasonic MSX2+ rom. Also tried this with NMS8245 ROM, the same happened.

After destroying Metal Gear and defeating Big Boss, I had to take the stairs upstairs once again. Just to play around a bit I thought, why not play a fool and take the middle stair. And guess? Snake just climbed all the way trough over the wall!
It seems when taking the stair at the most left position of the stair you can take, Snake does a Loony Tunes action and just climbs up without a ladder. I will try this again in BlueMSX, as I am not sure if this is an emu-bug or an MG bug.

Anyone noticed this before or anyone that can confirm this?

Login or register to post comments

By Konamito

Paladin (975)

Konamito's picture

15-05-2006, 17:20

Dude, this is incredible... I'll try to test it if I found my savegames somewhere...

Tell us about it as soon as you test it Wink

By Rataplan

Master (161)

Rataplan's picture

15-05-2006, 20:40

Well this is what actually happens, atleast with fMSXSO:

rataplan.ath.cx/msx/fMSXSO005.png
rataplan.ath.cx/msx/fMSXSO006.png
rataplan.ath.cx/msx/fMSXSO007.png
rataplan.ath.cx/msx/fMSXSO008.png

also on the right ladder:

rataplan.ath.cx/msx/fMSXSO000.png

as you can see the game still finishes when you not take the left ladder. This makes Jennifers brother a bigass fat liar, better walk back in and spank him :D

By poke-1,170

Paragon (1669)

poke-1,170's picture

16-05-2006, 11:15

in those days, you had to cut down on memory in gamecartridges.
this is a typical example of saving valuable cartridgespace Wink

By Huey

Prophet (2483)

Huey's picture

16-05-2006, 15:10

Can't see how this would save memory. I'm guessing that this final part (climbing stairs) runs through the main game engine. (Thats what I would do). So I don't think it is a memory issue.

By Rataplan

Master (161)

Rataplan's picture

16-05-2006, 16:08

hehe, I think poke was making a joke (hey that rhymes). Ofcourse this has nothing to do with memory saving. I will try to find the time to finish the game in BlueMSX this week, to see if it works there too. If so, it must be a bug in MG itself.

Are there by the way more than one version of the Metal Gear cartridge/rom? By that I do not mean any translated roms, but version released by Konami.

By snout

Ambassador (14859)

snout's picture

16-05-2006, 17:43

I don't think it's a bug in MG, but in emulation... probably the emu does some sort of skipping/shifting which causes reaching the end of the middle stairs not to be detected properly. I'm quite sure I took the wrong stairs in the old days a couple 'o times Wink

By Edwin

Paragon (1175)

Edwin's picture

16-05-2006, 18:44

But did you walk on up and try to walk off the ladder after the end came into view? Or did you just turn around like the rest of us. Smile

By Rataplan

Master (161)

Rataplan's picture

16-05-2006, 20:21

Well I tried BlueMSX, going up to the end, and then saving to tape. After that I tried several configurations. The screenshot below is from a Philips NMS8245 romset.

rataplan.ath.cx/msx/bluemsx%20mgear%20finish.png

seems to be a bug in the game after all. Too bad I do not have an original Metal Gear cartridge anymore to try it on a real MSX :'(

I saw another 'problem' right along, completely offtopic, but BlueMSX uses one layer of AntiAliasing on my screen, even if the Video-filter is set to 'none', but only in full-screen modus. Any switch to disable that?

By Konamito

Paladin (975)

Konamito's picture

16-05-2006, 20:24

I have the original game but I don´t have much spare time for playing the entire game till the end (sorry I have no Cassette neither) Sad

By dvik

Prophet (2176)

dvik's picture

16-05-2006, 21:10


I saw another 'problem' right along, completely offtopic, but BlueMSX uses one layer of AntiAliasing on my screen, even if the Video-filter is set to 'none', but only in full-screen modus. Any switch to disable that?

It may be that the full screen resolution chosen by blueMSX is different from your monitor. Especially on LCD's you'll see anti aliasing effects if the resolution in the emulator is not an integer multiple of the LCD resolution.

You can try to change the fullscreen resolution in the properties page.

Page 1/6
| 2 | 3 | 4 | 5 | 6
My MSX profile