Link to Youtube videos with time mark do not work in MRC Wiki?

بواسطة defdanny

Master (156)

صورة defdanny

19-05-2020, 21:28

Hi Wiki experts,
I am extending a wiki article and wanted to add some links to certain youtube videos.
The wiki link format with the 2 "[]" brackets works fine, except it dismisses the URL params for the time mark!
Example:
Say I want to link to second 30 in an ingame video, the link looks like https://youtu.be/BGLMbCalF_g?t=30
This link should lead straight to second 30 in the video... but it does not work in MRC Wiki context.
When I use the wiki method for external links, the parameter "t=30" is cut off. :(
Any ideas?

Login أوregister لوضع تعليقاتك

بواسطة FiXato

Scribe (1602)

صورة FiXato

19-05-2020, 23:27

instead of 't' use 'start', as that is what the YouTube embed uses, e.g.: ?start=30
https://youtu.be/BGLMbCalF_g?start=30
Be sure to specify the time in second, and leave the 's' (or other time-format letters such as m and h) out of the timestamp.

You should be able to also specify an end-time with end=TIME_IN_SECONDS
https://youtu.be/BGLMbCalF_g?start=30&end=35
(Unfortunately the end-time only seems to work in the embedded player, not on the actual YouTube video page.)

For more info regarding to the parameters the YouTube embed supports, see https://developers.google.com/youtube/player_parameters

بواسطة Grauw

Ascended (9176)

صورة Grauw

20-05-2020, 00:30

I added a note about that to the wiki section of the MRC Troubleshooting FAQ.

By the way, I notice this is different from the advice given for the forum. Do the forum templates attempt to transform the URLs to suit the embedded player? (Which the wiki does not?)

بواسطة defdanny

Master (156)

صورة defdanny

20-05-2020, 14:20

Hi FiXato, Hi Grauw,
thank you for clarifing that! I will use the "start" parameter in my links!
Many thanks!!!

بواسطة ren

Paragon (1457)

صورة ren

20-05-2020, 16:16

FiXato wrote:

instead of 't' use 'start', as that is what the YouTube embed uses

Yes, but I'd like to stress that using that for links is a workaround / not officially documented (AFAICT) Smile (@anyone: workarounds are needed here as the YT link parsing & embedding is quirky/outdated.)

Well the stuff in the FAQ is workaround galore anyway. I did some test, not sure if the old workaround that was already in place for the forums still works? (I think I would have to test actually posting some (new) stuff). Anyway, personally the workaround for me is to open a YT link in a new tab.

@Grauw: I believe the behavior was somewhat different, but when I initially wrote that bit, it was with the forums in mind indeed.

Are you sure the xhymzs format is part of ISO 8601?

ISO 8601 uses the 24-hour clock system. The basic format is [hh][mm][ss] and the extended format is [hh]:[mm]:[ss].

-edit, while I'm at it, old workaround: https://www.youtube.com/watch?v=BGLMbCalF_g&t=0m30s (does still work here)
E.g. this won't work: https://www.youtube.com/watch?v=BGLMbCalF_g&t=30

https://youtu.be/BGLMbCalF_g?t=0m30s (no worky)

Well, using the short url with start does look nicest :)