Faulty Mitsumi D357 Disk Drives

بواسطة hansgoos

Supporter (16)

صورة hansgoos

16-04-2021, 13:13

Hi All,

I have two Mitsumi D357 disk drives and both have the same issue. When I try to read from them I'm getting "Disk Offline" and when I try to format a disk, the drive spins for a second, the head is moving a bit and then I get "Bad parameter" (choosing between single side / double side doesn't make any difference).

Does anyone know if those drives can be fixed?

The MSX (8250) is OK because I have a third drive which is wrking fine.

Login أوregister لوضع تعليقاتك

بواسطة Meits

Scribe (6446)

صورة Meits

16-04-2021, 13:31

Can you take a look inside the drive? Is the top head still on its place?
Those drives have a mechinacal flaw that lets you eject a disk while not pressing the eject button to its end. You get the disk out but the top head goes down again. If you insert a disk, you risk forcing the top head off.

بواسطة hansgoos

Supporter (16)

صورة hansgoos

16-04-2021, 13:45

I already took the top cover off. I cleaned the heads and all looks normal (see picture)

بواسطة Meits

Scribe (6446)

صورة Meits

16-04-2021, 14:31

There's no belt in these drives so no need to for that subject.
A few weeks ago I ran into a broken disk sense microswitch in another old MSX diskdrive. I'm not sure how sensitive these switches are in those diskdrives, but you could check them. It might be broken and stuck in no disk position.

بواسطة jltursan

Prophet (2541)

صورة jltursan

16-04-2021, 14:37

I've seen a lot of these drives failing like this and also, a variant where you can format a disk; but the verifying procedure always fail in the first track. Never been able to find an easy solution: no cleaning, no greasing or cap replacement have fixed the fault.
Is there a way, using a MSX tool, to selectively format/access a disk with only a head?. If so, you can try to find if it's a head related problem; but I doubt it, the "Disk offline" error seems to be unrelated.

بواسطة Repair-Bas

Paragon (1125)

صورة Repair-Bas

16-04-2021, 15:32

The upper head is a little bit out of position.

Please try to format ss?

بواسطة hansgoos

Supporter (16)

صورة hansgoos

16-04-2021, 16:00

Single-Side format gives the same result (" Bad Parameter ")

بواسطة Alexey

Guardian (3204)

صورة Alexey

16-04-2021, 17:18

I have a few of these drives. Tried to fix them but without success - they just don't work. Something with the track 0 sensing, I believe. These drives have 2 types of sensors - either optical, or magnetic for write protection and disk presence. Those can get dirty or fail, but in my case they were OK. Also, there's an optical track 0 sensor, I tried to adjust it, but it didn't work. The drive formats a diskette, but can't complete formatting. It could be that the heads don't write or read the disk. I am going to try to use an oscilloscope on one of the drives to see what's going on during read or write operations.

بواسطة jltursan

Prophet (2541)

صورة jltursan

16-04-2021, 21:04

In the Commodore world there's a common (and deadly) fault with their drives: the head oxidizing. Seems that the Mitsumi/Newtronics heads suffer from internal oxidizing or any other kind of degradation and its resistance increases a lot ruining the head. Alps mechanisms doesn't suffer this problem.

Being also a Mitsumi drive, maybe it's worth to check the head resistance against a 100% working one?