Black screen on startup

صفحة 1/2
| 2

بواسطة herres88

Rookie (26)

صورة herres88

29-06-2021, 14:44

I have a NMS8250 which doesn’t work at startup. I tried every outlet and it seems it gives power to the outlets, but it just stays black. When i press te power button multiple times, you can see a white screen flashing by quickly.

Also, the keyboard has the caps light on permanently. I can’t get the capslock light to go out.

How can i fix this?

Login أوregister لوضع تعليقاتك

بواسطة AndreV

Expert (128)

صورة AndreV

29-06-2021, 16:22

Maybe the battery is leaking?
also you can try Press [GRAPH]+[STOP] try typing color 15,4,4

بواسطة herres88

Rookie (26)

صورة herres88

29-06-2021, 17:02

Doesn’t do anything.

بواسطة herres88

Rookie (26)

صورة herres88

29-06-2021, 17:29

Also, it does indeed look like the battery is leaking.

بواسطة AndreV

Expert (128)

صورة AndreV

29-06-2021, 19:36

Remove the battery as quick as posible and clean the leaked area with vinegar,

بواسطة herres88

Rookie (26)

صورة herres88

29-06-2021, 20:13

And after i did that ?

بواسطة Meits

Scribe (6476)

صورة Meits

29-06-2021, 21:03

The battery used in the 8250 (a yellow/black AA look-a-like) is sealed and not suspect to leaking. But it might probably be dead. That will not influence the working of the computer except for settings/time being lost during a power cycle.
The battery is located underneath the right diskdrive and can be just cut off.

بواسطة AndreV

Expert (128)

صورة AndreV

29-06-2021, 21:21

Try to see what the damage is, i can't tell what to do next. Can't look into the computer.

Clean the area after the vinegar with alcohol.

بواسطة msxholder

Champion (394)

صورة msxholder

29-06-2021, 23:21

Just push once the service button !
And i can see it is a modified 8250
This is an other subrom and diskrom with a wire to subrom.

بواسطة Meits

Scribe (6476)

صورة Meits

30-06-2021, 02:17

msxholder wrote:

Just push once the service button !
And i can see it is a modified 8250
This is an other subrom and diskrom with a wire to subrom.

i doubt the picture of AndreV is the MSX in question

بواسطة Alexey

Guardian (3286)

صورة Alexey

30-06-2021, 12:43

In my experience, bad RAM or VRAM is one of the most common reasons for the black screen at startup. Second most frequent reason is bad video encoder (notorious HIC board or LVA510 chip, for example). I've also seen faulty VDPs, but not as frequent as broken RAM. There could be tens of other reasons as well. Usually it's necessary to have a physical access to the machine to identify what's wrong.

You might want to try to insert a RAM expansion into slot 1 and see if there is any change. Also, for Philips machines there are diagnostic ROMs that can be put into a slot and with a flip of a switch your cartridge becomes the BIOS. If your main BIOS is socketed, you can even try to write such diagnostic ROM into the EEPROM chip and replace the BIOS chip to boot from that ROM.

https://hansotten.file-hunter.com/special-msx-hardware/phili...

صفحة 1/2
| 2