bad file mode

Por Visualedu

Resident (33)

Imagen del Visualedu

20-09-2018, 22:51

Hola,
estoy creando un jueguecito en ensamblador (sjasm Y openMSX).
Compilado ocupa 26 KB y lo situo en la dirección 8200 de origen.
Estaba en la tarea de implantar un player de pt3, pero cada vez que cargo el binaro (BLOAD"SM") salta el error
'bad file mode' y vuelve al DOS. (No veo manera de debugarlo Sad )

Sucede tras cargar el binario PERO SIN EJECUTARLO (bload'sm') (sin el ',r')
No entiendo cual es el problema si el binario ocupa 24kb (menos de 32kb)

¿Alguien se le ocurre a que se puede debe el error?

Gracias, Visualedu

Login sesión o register para postear comentarios

Por Juan Luis

Resident (46)

Imagen del Juan Luis

11-04-2019, 13:15

Visualedu wrote:

Hola,
estoy creando un jueguecito en ensamblador (sjasm Y openMSX).
Compilado ocupa 26 KB y lo situo en la dirección 8200 de origen.
Estaba en la tarea de implantar un player de pt3, pero cada vez que cargo el binaro (BLOAD"SM") salta el error
'bad file mode' y vuelve al DOS. (No veo manera de debugarlo Sad )

Sucede tras cargar el binario PERO SIN EJECUTARLO (bload'sm') (sin el ',r')
No entiendo cual es el problema si el binario ocupa 24kb (menos de 32kb)

¿Alguien se le ocurre a que se puede debe el error?

Gracias, Visualedu

Visualedu, yo no sé mucho de esto, y a lo mejor lo que te estoy sugiriendo es de perogruyo y ya lo sabes, pero lo que se me ocurre es lo siguiente:

¿pones al principio del binario la cabecera del binario correctamente? Es decir, algo como esto:

org #8200 - 7

db 0xfe; Header of .BIN MSX file ; Cabecera archivo .bin MSX Basic
dw main ; Comienzo del binario
dw ending ; Final del binario
dw main ; Dirección de comienzo de ejecución

main:

ending:

o bien ¿en las opciones del ensamblador le dices que te genere un ejecutable .bin de MSX?

Por jrcp_kun

Paragon (1410)

Imagen del jrcp_kun

12-04-2019, 13:02

eso es error en la creacion del fichero de compilacion
no vayas a estar creando un .rom