Creo que me he cargado el MSX

Página 1/2
| 2

Por Popolon

Supporter (15)

Imagen del Popolon

22-03-2019, 06:28

Hola,
Animado por todo el movimineto de 8bits del MSX,ayer rescate de una caja que tenia en casa un viejo MSX1 SPECTRAVIDEO 728, me mire unas cuantas paginas para el tema de limpiarlo, y hacerle una puesta apunto, asi que lo desmonte par limpiarlo. Antes de hacerlo, lo enciendi y el BASIC arrancaba bien, auqnue el cursor se movia solo.

Animado por que todavia funcionaba, lo desmonte todo,limpie las teclas, las carcasas, y luego al volver a montarlo no se me enciende :-( mierda mierda !!!!

-La tecla mayusculas no va ni se enciende
-Me sale como un recuadro en verde y ahi se queda
-LA primera vez, hacia como un "clak,clak,clak" dos o tres veces, luego nada.
-El power ON se enciede, y las mayusculas a veces quedan encenidas pero no se puede apagar.

He mirado todo y no veo nada torcido o roto, en fin alguien me puede ayudar? que puedo haber tocado para que antes se encienda y ahora no??

Gracias

Login sesión o register para postear comentarios

Por PAC

Guardian (5139)

Imagen del PAC

22-03-2019, 17:40

Difícil saberlo. El "clak clak clak" que comentas debe ser un relé de la fuente. Pudiera ser que los problemas vinieran de la fuente. Echa un ojo a este hilo por si te ayudara, comenta algo parecido de un SVI-738:

https://www.msx.org/forum/msx-talk/hardware/help-needed-with...

No sé qué llegaste a desmontar, vuelve a revisar conexiones (pines doblados...) aunque supongo ya lo habrás hecho. Tampoco te comas la cabeza, puede haber sido perfectamente una coincidencia. Es electrónica con más de 30 años a sus espaldas y aunque haya estado sin usar durante un largo tiempo todo envejece. Aquí tienes varios manuales de tu modelo incluido el de servicio por si te sirvieran:

http://msx.hansotten.com/manuals-and-guides/svi-328-and-svi-...

Por Popolon

Supporter (15)

Imagen del Popolon

22-03-2019, 18:05

Dicen que el clak clack clack es un cortocircuito.Estoy practicamente seguro que es esto.
Supongo que entonces la averia esta en la parte de la fuente.Que tendira que cambiar?

[img]IMG-20190322-143845518
image host
[/img]

Esta es la foto de la parte de la fuente.
No identifico nada mal, el relee que dices donde estaria?
Voy a medir tambien los voltios de los condensadores .
Donde se puede conseguir material de este tipo para msx?

Gracias

Por PAC

Guardian (5139)

Imagen del PAC

22-03-2019, 18:40

Hay que empezar mirando que los voltajes que da la fuente a su salida son los correctos 5V, 12V y -12V (página 137 del PDF). Así ya acotamos el problema.

Quitando los chips específicos de un MSX (VDP, PSG, etc) los demás son componentes genéricos que se pueden encontrar, salvo alguna excepción, en cualquier tienda de electrónica.

Por jrcp_kun

Paragon (1410)

Imagen del jrcp_kun

24-03-2019, 16:07

haz una cosa ya que has andado toqueteando
coge un compresor o vete a una gasolinera y soplalo a conciencia- Luego vuelve a probar.
y a partir de ahi empiezas con cortocircuitos y demas

Por Popolon

Supporter (15)

Imagen del Popolon

24-03-2019, 16:31

Gracias pero la verdad es que esta bastante limpio, ha dormido bien esos casi 30 años.De todas maneras, lo hare.

Ademas arranco el BASIC sucio, ahora deberia arrancar tambien.
Hoy voy a probar voltajes de transistores, no se ve ninguno hinchado, pero podria haber alguno cortocircuitado.
Estoy casi seguro que sera un cortocircuito, en algun lado. Dare mas detalles luego.
AL verse la pantalla como un recuadro verde, significa y CPU que la grafica funcionan, en teoria.Eso he
leido por ahi.
Tampoco arranca con el NEMESIS2 puesto.Sale el mismo recuadro verde,muy tenue.

Pongo la foto entera, por si alguien ve alguna cosa rara y me puede ayudar.

[img]IMG-20190322-143855968[/img]

-

Por Popolon

Supporter (15)

Imagen del Popolon

27-03-2019, 06:23

Bueno ,pues he detectado como minimo un condensador que no me pita bien (es el de la derecha de la foto, no esta hinchado, pero no marca bien), y me da valores de 0.000, asi que debe estar dañado.El problema es que de electricidad se lo basico, y no tengo soldador ni recambio de condensadores, asi que a ver por cuanto me sale la broma.Un equipo de soldadura son unos 20 pavos en amazon.

Luego he visto una tienda que reparan ordendores de 8 bits, por 20-40€ (segun me han dicho), asi que al igual me sale mas a cuenta llevarlo. A ver que hago ,porque la verdad es que tambien me apetece curar "al peque" por mi mismo,como hobby sin prisa. Auqqnue si la cosa se complica con reprogramacion de chips y demas historias...ya veremos.

Voy a medir tambien los capacitadores,pero es incomodo de trabajar por el tema de no poder levantar bien el teclado por la cinta esa del teclado que molesta que no veas.

Por AbrahamCas

Expert (66)

Imagen del AbrahamCas

27-03-2019, 08:32

Una curiosidad(sin ser experto en electronica), tengo entendido que para comprobar un condensador es necesario extraerlo del circuito en el que está, y como comentas que no tienes soldador...como lo has medido?
Un saludo

Por PAC

Guardian (5139)

Imagen del PAC

27-03-2019, 10:04

Ahora mismo estás dando palos de ciego, cambiarás mil cosas, te gastarás el dinero en componentes, soldadores, etc y no darás con el problema. Como ya te comenté empieza comprobando los valores que da la fuente de alimentación a su salida. Hay que trabajar de manera ordenada para acotar el problema. Mi recomendación es que lo lleves a reparar o inviertas ese dinero en otro MSX.

Por Popolon

Supporter (15)

Imagen del Popolon

27-03-2019, 11:11

Se puede medir los condensadores sin sacar de la placa, pones el multimetro en escala diodo y te pita y sale OL si es OK, los capacitores (lentejuelas) casi siempre dan 0,15 todos, asi que estan bien,menos 1 creo, que cambiare porsiacaso.
Las resistencias son mas jodidas, pq son pequeños y es un poco lio saber lo que tienen que dar, asi que espero que esten bien.Tengo entendido que casi no se funden nunca.

Lo condensadores son muy baratos ) (1-2 euros) , de momento solo me gastare con el soldador, y asi ya lo tengo.
Si despues de cambiar tres o 4 componentes, sigue sin funcionar, lo llevare a reparar, y solo me hbare gastado unos 22€, y y ya tengo un soldador,que siempre puede venir bien.

La fuente no se si la estoy midiendo bien, como hacerlo exactamente y que tiene que darme?

En todo caso hay un condesador torcido, que no pita, o sea que esta mal, como minimo cambiare ese esta noche, y haber que pasa.En la foto no se ve, esta debajo de la cinta.
Tambien tengo que medir los transistores, que hay bastantes.

Por AbrahamCas

Expert (66)

Imagen del AbrahamCas

27-03-2019, 11:32

Buenas de nuevo,
Si pones el polimetro en la posicion diodo como comentas lo que mides es la continuidad no la capacidad(condensador==capacitor). Para ver que un condensador está trabajando como debe hay que comprobar que carga correctamente y que alcanza los valores cercanos a los que marca su curva y para eso es necesario sacarlos del circuito al cual pertenecen.
Respecto a las resistencias es raro que fallen(para esto si utilizaría la comprobacion de continuidad) pero en cualquier caso tienes varias opciones para saber su valor. Si son de las "normales" llevan su codigo de colores que puedes consultar, si son SMD llevan un codigo que igualmente es cuestion de consultar la tabla y si consigues el esquema eléctrico del ordenador suele venir una lista de componentes con sus valores.
Los transistores requieren igualmente sacarlos del circuito para comprobarlos.

Yo empezaría por la fuente de alimentacon como comenta PAC , en la pagina de Hansotten que te ha puesto el más arriba tienes tanto el manual de servicio de tu modelo como el esquema eléctrico completo. La forma de comprobar la fuente es poner el polimetro en posicion para medir voltios, ajustar la escala a 20 y comprobar las salidas de +12,-12 y +5V, para ello punteas con el neutro(COM) en masa y con el rojo vas comprobando valores.
No obstante si no tienes muy claro lo que estas haciendo te aconsejo que te asesores, pues te puedes llevar una sorpresa desagradable en forma de descarga electrica o quemar algo del equipo.

Ánimo con ese equipo!!! y mucha paciencia.

Página 1/2
| 2