MegaFlashROM SCC+ SD

Página 117/118
110 | 111 | 112 | 113 | 114 | 115 | 116 | | 118

Por abasira

Expert (68)

Imagen del abasira

11-07-2020, 00:58

Muchas gracias... Me va a venir genial para algunos modelos de msx que tengo

Por Guillian

Prophet (3325)

Imagen del Guillian

11-07-2020, 22:32

Por favor, comentad si funciona bien y se salta el firmware sin necesidad de pulsar ninguna tecla.

Por knm1983

Champion (489)

Imagen del knm1983

12-07-2020, 11:11

Hola Guillian , probado en el MLG1 y no funciona , o sea , al encender el ordenador , sale un instante la
Detección de la SD y se queda la pantalla en azul , no llega a salir ni multimente ni nada , además no es posible entrar en el recovery con el cursor hacía arriba.
La actualización la he probado en el turbo R y accede perfectamente al recovery y arranca todo , pero en el MLG1 no , ni siquiera pulsando la Tecla Del para evitar el menú interno.

Por knm1983

Champion (489)

Imagen del knm1983

12-07-2020, 11:24

Te he subido un vídeo al drive para que veas mejor lo que hace.
https://drive.google.com/file/d/1qvwQv0QgMPA7i4ry-sRfklpYTG3...

Por knm1983

Champion (489)

Imagen del knm1983

12-07-2020, 11:38

También lo he probado en el MLG3 con 64k ram y ahí funciona perfectamente , pero claro este no tiene menú interno.

Por Guillian

Prophet (3325)

Imagen del Guillian

12-07-2020, 15:44

Gracias por probarlo.
Para evitar que se salte automáticamente el firmware pulsa la tecla BS. Si pulsas BS y cursor arriba debería entrar en el menu recovery.
De todas formas, he actualizado la ROM para que compruebe antes el cursor arriba sin necesidad de pulsar BS.

En el openMSX sí se salta el firmware del ML-G1ES, así que quizá esté probando una configuración distinta.
¿Tiene tu MFR SD 512KB RAM? ¿Tiene la ROM Disk instalada?

Edit: ¿Recuerdas sin con la versión anterior al pulsar F3 se saltaba el firmware?

Por knm1983

Champion (489)

Imagen del knm1983

12-07-2020, 18:34

Hola , no mi MFR es sin ram , lo que no puedo decirte como funcionaba antes ya que en este ordenador no la he usado nunca.
En un ordenador que tengo de hace un par de años y no lo uso habitualmente.
Lo del F3 tampoco lo había probado anteriormente.
Probaré esta nueva rom a ver que tal y ya te contaré. Smile

Por Guillian

Prophet (3325)

Imagen del Guillian

12-07-2020, 19:43

Entonces tampoco le des más vueltas. La idea es poder arrancar Nextor en esos equipos.
El problema está en que el firmware interno normalmente interfiere con el arranque de MSX-DOS2 / Nextor y acaba arrancando en DOS1.
Si no tienes RAM en el cartucho, no te arrancará Nextor porque necesita 128 KB como mínimo.

Lo que que he hecho es desactivar que se salte el firmware si no hay RAM en el cartucho. El link es el mismo.
Gracias por las pruebas.

Por knm1983

Champion (489)

Imagen del knm1983

12-07-2020, 22:29

Bueno lo probaré de todos modos ya que tengo la ampliación de 1mg que utilizo en el G3 y probar a ver que pasa.
Ya te contaré a ver que ocurre , gracias a ti por estas mejoras Smile

Por knm1983

Champion (489)

Imagen del knm1983

13-07-2020, 14:42

Bueno ya he probado con el nuevo Recovery , ahora en el MLG1 se queda en un bucle haciendo resets mostrando el logo de Msx , o sea hace lo mismo que antes que salía el logo de msx en el arranque y después se veía un instante la detección de la SD , pero ahora , en vez de quedarse en pantalla azul , vuelve a hacer reset y así se queda en un bucle haciendo resets mostrando el logo de Msx y la detección de Sd un instante.
Por otro lado en el MLG3 arranca sin problema el Dos1 con las 64k.

También hay buenas noticias , le he puesto el Mega de ram en el slot 2 y en este caso , arranca sin problemas , saltándose el programa interno del G1 sin pulsar ninguna Tecla y arrancando perfectamente Multimente y funcionando a la perfección.

Página 117/118
110 | 111 | 112 | 113 | 114 | 115 | 116 | | 118