Megaflashrom: I can't hear the audio

Página 1/6
| 2 | 3 | 4 | 5 | 6

Por StephenM

Rookie (27)

Imagen del StephenM

06-10-2010, 13:47

Well,

I'm new to the megaflashrom world,

The default demo's worked fine
but I can't hear any audio from a rom I upload....

I use it on a Philips NMS 8280

Or Is there any FAQ for the Megaflashrom???

Kindly,
StephenM

Login sesión o register para postear comentarios

Por Guillian

Prophet (3258)

Imagen del Guillian

06-10-2010, 14:43

It is a problem related to some Philips computers
From MSX FAQ: http://www.faq.msxnet.org/miscfaq.html


The sound on my Philips NMS 8250/55/80 sounds terrible. How can I fix it?

Yes, a lot of NMS8250/55/80 computers have an assembly error in the audio output circuitry. This is probably the case. To fix it:

* NMS 8250/55: R428&R429 (100R) should both be replaced by an elco 100uF/10V with the negative side towards connector `AB'
* NMS 8280: R426 (100R): replace by 100uF/10V (same as above)

You can also use /P option to patch Konami games in order to use the external PSG in the MegaFlashROM SCC+

Por Repair-Bas

Paragon (1076)

Imagen del Repair-Bas

06-10-2010, 14:52

I think that is not the problem.

What msx-audio you use? and with what roms?

Can you try to start-up the internal program of the msx-audio?

If you than have the program without sound you have problem in your computer.

Then IC1052 is broken mostly (7912: power-regulator)

Por StephenM

Rookie (27)

Imagen del StephenM

06-10-2010, 15:44

Well, I tried Galaga, Vampire killer and Slaydock....

I have original roms, for example Salamander, and that's still fine.

The default audiodemo's on the megaflashrom had also audio,
but I overwrote it by "OPFX slaydock.rom /B0"

I'm gonna try that /P option..

Por StephenM

Rookie (27)

Imagen del StephenM

06-10-2010, 15:49

Wen I unplug the Megaflashrom, Everything is okay,
I even hear the click when typing...

When I plug the Megaflashrom, the audio is disabled..
Maybe soms hardware issue,
but strange my salamander rom works fine !!?

Por StephenM

Rookie (27)

Imagen del StephenM

06-10-2010, 16:04

And when I plug Salamander ànd the MegaFlashrom,
Salamader also doesn't has sound..

hmmm, maybe there's something wrong with my Megaflashrom !!??

to bad I have overwritten the default progs, cause they had sound..

Por Guillian

Prophet (3258)

Imagen del Guillian

06-10-2010, 17:45

It is probably due to an error in the audio mixer of your Philips.
Just test the MegaFlashROM SCC+ in any other computer and it should work fine.
Also, try the /P option to get PSG sound in Konami games if you don't want to modify your computer.

Por StephenM

Rookie (27)

Imagen del StephenM

06-10-2010, 18:21

Well,
to bad for me, I don't have another MSX Computer

And so far the /P option doesn't do it...

?? Do I need this /P when saving the rom to the megaflashrom,
or is it a command that changes when exec process ??

Anyway, So far I'm sure the Megaflashrom reconnects the audio signal path, by hardware.

And about the audiomixer of the NMS 8280, can this be fixed by these elco's ???
It's because only the megaflashrom gives problems with the audio..??

Por Repair-Bas

Paragon (1076)

Imagen del Repair-Bas

06-10-2010, 19:09

those 2 elco's are only for using an external soundchip.

Por StephenM

Rookie (27)

Imagen del StephenM

06-10-2010, 19:27

okey, I'll take a look at this elco replacement feature..

Por Guillian

Prophet (3258)

Imagen del Guillian

06-10-2010, 19:29

Another user had a simiilar problem and fixed it by replacing that resistors.
MegaFlashROM SCC+ is an external sound source (SCC and PSG). So I think the mixer puts all the priority / balance in this cartridge. That's why you can hear the sound demos but not the internal PSG.

Página 1/6
| 2 | 3 | 4 | 5 | 6