MSX перестал работать, есть ли шансы оживить?

Página 2/2
1 |

Por caro

Champion (512)

Imagen del caro

08-12-2011, 15:57

Затем не мещает проверить сигнал на ножке 16(INT/). Если чип VDP (9928) работает, здесь должны быть короткие импульсы с частотой кадровой развертки.
Тут тоже на первый взгляд все как надо: характерная пилообразная картинка развертки.
Да нет, на 16 ножке процессора должны быть короткие импульсы низкого уровня с частотой кадровой развертки, не пила.

Por misterspin

Resident (56)

Imagen del misterspin

08-12-2011, 19:55

Да нет, на 16 ножке процессора должны быть короткие импульсы низкого уровня с частотой кадровой развертки, не пила.
Понял. Гляну вечером и отрапортую.

Por misterspin

Resident (56)

Imagen del misterspin

10-12-2011, 20:01

Вот, померил не торопясь и выложил картинки:
https://sites.google.com/a/vassenkov.com/hitachi-mb-h2/oscilloscope-check-z80

На 16 ножке все правильно, нет? Вроде да, короткие, низкого уровня импульсы.

Por caro

Champion (512)

Imagen del caro

11-12-2011, 13:05

Вот, померил не торопясь и выложил картинки:
На 16 ножке все правильно, нет? Вроде да, короткие, низкого уровня импульсы.
Не вижу на картинке никаких импульсов. Судя по следующим картинкам VDP не инициирован.
Если как я понял, на всех картинках масштаб по вертикали одинаков, то судя по всему сигналы на ножках 20 и 22 подсажены по амплитуде. Так бывает когда выходы процессора подключены к входам неисправных микросхем. Проверяй все микросхемы, к входам которых подключены эти ножки.
На будущее, желательно что бы осцилограф был включен по входу на постоянном токе.
И на каждой картинке был указан масштаб развертки по амплитуде и по времени.

Por misterspin

Resident (56)

Imagen del misterspin

12-12-2011, 16:37

...Проверяй все микросхемы, к входам которых подключены эти ножки...
На многих мелких чипах, похоже, вообще нет активности. Я правильно понимаю, что там как минимум тактовая частота должна быть?

Por misterspin

Resident (56)

Imagen del misterspin

16-12-2011, 01:47

@caro:
Откалибровал осциллограф, померил по новой и выложил здесь:
На первом кадре - тактовая частота, для масштаба.
По вертикали - 2 вольта на одну клетку.
Все снимки - в одном масштабе.
https://sites.google.com/a/vassenkov.com/hitachi-mb-h2/oscilloscope-check-z80

На 16 ножке 5 вольт и больше ничего нет.
Значит ли это, что видео процессор не работает?

На 19 и 22, да, что-то левое.

Поменять VDP сначала?

Por misterspin

Resident (56)

Imagen del misterspin

16-12-2011, 05:21

... в смысле, на 20 и 22 странное что-то.

Página 2/2
1 |