Sound disappears in BlueMSX

Por YuN

Rookie (22)

Imagen del YuN

24-08-2013, 16:33

BlueMSX is, generally, great, but one of its greatest features - saving and loading "CPU state", that is, saving and loading games which normally don't allow it, after several loadings makes sound to disappear. Everything else works OK. Even the cold reset (of virtual MSX) does not help - only exiting BlueMSX and starting it again. Does anybody know how to fix it?

Login sesión o register para postear comentarios

Por Randam

Paragon (1417)

Imagen del Randam

24-08-2013, 17:34

Never saw that happen. What configuration are you running and what version of Bluemsx?

Por YuN

Rookie (22)

Imagen del YuN

24-08-2013, 20:36

version 2.8.2
configuration is mostly default for MSX2.

Por nanochess

Master (222)

Imagen del nanochess

05-09-2013, 22:15

I never had that problem. However the most common problem for me, is when sometimes (very rarely) the saved state crashes.

Por YuN

Rookie (22)

Imagen del YuN

05-09-2013, 22:43

I noticed that loading crashes when you use key combination while menu bar is shown (if it is shown, you have to use mouse; this is a bug, of course). But the disappearance of sound after several loadings is another problem.

Por dink

Expert (73)

Imagen del dink

06-09-2013, 19:45

Hello YuN,
I am a BlueMSX 2.8.2/2.8.3 beta(December 2010) user & use savestates a lot, usually around the 15th time I've save 'n loaded a savestate, the sound will disapear, or sometimes BlueMSX will crash. I found that the best thing to do is close & reload BlueMSX then Quick Load State to restore the game.
p.s. I use a PS3 wireless gamepad with Quick Save State mapped to L1 and Quick Load State mapped to R2.

best regards,
- dink