Arcade Game Designer for MSX

Página 14/14
7 | 8 | 9 | 10 | 11 | 12 | 13 |

Por jltursan

Prophet (2457)

Imagen del jltursan

12-12-2020, 11:32

zPasi wrote:
jltursan wrote:
  • The game freezes randomly when sprite flicker is happening.

I think this fixes that bug:

.fullsat:
		sub colltab&$FF
		jr z,.zerolen
		ld c,a
		ld hl,colltab
		ldir				; copy 2nd half
.zerolen
		ld a,$D0			; no more sprite from here

Indeed the freezing bug was "colltab" related, thanks for pointing this out Smile. This table meant to be an aligned one and I missed it; so, the freezing did happen when there're flickering sprites and the random table position makes it cross a 256 byte boundary. Now the table it's always aligned Running Naked in a Field of Flowers

The MSX2 version badly needs full mode 2 sprites. I need to implement an OR3 mechanism to solve this; but of course, it'll support them Smile

Por McCheeseBob

Supporter (3)

Imagen del McCheeseBob

03-03-2021, 22:16

I've been interested in making some older computer games for awhile and I've always loved the MSX. I've been fiddling with MPAGD for the past few days and it is really nice to use, especially for someone who isn't great at programming such as myself. For some reason though I haven't been able to get music working using the basic commands as listed on Github. Using a shell of a game and the demo PT3 included in the Cold Snap zip I've been able to use the DEFINEMUSIC command fine (I think) in the Game initialization screen, but any time I put MUSIC <1> <1> into the main loop I get an error when compiling the AGD source (usually a not a number/variable and missing argument). I don't get these errors when I remove just the music line. What am I doing wrong? (Also sorry if this is the wrong place to post this).

Por McCheeseBob

Supporter (3)

Imagen del McCheeseBob

03-03-2021, 22:22

Woops double post, didn't think my first message went through.

Por UltraNarwhal

Rookie (21)

Imagen del UltraNarwhal

03-03-2021, 23:38

McCheeseBob wrote:

For some reason though I haven't been able to get music working using the basic commands as listed on Github. Using a shell of a game and the demo PT3 included in the Cold Snap zip I've been able to use the DEFINEMUSIC command fine (I think) in the Game initialization screen, but any time I put MUSIC <1> <1> into the main loop I get an error when compiling the AGD source (usually a not a number/variable and missing argument).

1. Make sure the pt3 file is in the MSX Suite\Resources folder. 2.Put MUSIC 1 1 in GAMEINIT event.

Por McCheeseBob

Supporter (3)

Imagen del McCheeseBob

04-03-2021, 01:04

Thanks! Silly me just forgot to remove the brackets.

Por jltursan

Prophet (2457)

Imagen del jltursan

04-03-2021, 09:34

And to stop any time remember to use:

MUSIC 0

Página 14/14
7 | 8 | 9 | 10 | 11 | 12 | 13 |