which emulator is error free

Página 2/2
1 |

Por Manuel

Ascended (18704)

Imagen del Manuel

24-03-2007, 00:02

Oh, I checked: the wave effect behaves the same in openMSX as in blueMSX: it stops about 10 lines too early...
Thanks for reporting this. I added an item in our bug tracker for this issue: http://sourceforge.net/tracker/index.php?func=detail&aid=1687188&group_id=38274&atid=421861

Por dvik

Prophet (2200)

Imagen del dvik

24-03-2007, 00:56

Its a very interesting bug, because 10 lines is like 3% faster which is very much. I'm not sure what the reason is for this big number but the TR timing is much more complicated than MSX2. A guess though is that its either some not so frequently used z80 instruction that has wrong timing and is executing a lot in this demo, or perhaps some VDP bus timing (although the latter is a bit less likely).

Por NYYRIKKI

Enlighted (5917)

Imagen del NYYRIKKI

24-03-2007, 07:56

Ah, you are always so quick. Smile

The part of the demo that is causing this problem goes something like this:

1 _TURBO ON
5 DEFINT A-Z
10 TIME=0:FOR I=0 TO 1:I=TIME:NEXT I
20 K=K+1:I=K
30 I=I+1
40 VDP(19)=M(I)
50 IF I-K<93 THEN 30
60 IF K<900 THEN 10

There is also another "feature" in this demo that I would like someone to verify...

On my real MSX tR it somehow seems that in the wave effect the color brightness on some lines is different than on neighbour horizontal lines. Is this caused by my monitor or is there some undocumented behavior in V9958?

Página 2/2
1 |