memory usage IDE

Página 1/2
| 2

Por TheKid

Paragon (1080)

Imagen del TheKid

18-01-2021, 15:52

I was wondering if there where any changes made to the memory usage when using IDE with a harddrive image? Reason I ask is that I have several programs that used to work with standard 128 Kb memory and now crash. When I use a 256Kb memory extension they work again?? I use openmsx for a long time, so I can't say since when it happenend. Version 15 and 16 have this behavoir.

Login sesión o register para postear comentarios

Por Manuel

Ascended (17460)

Imagen del Manuel

18-01-2021, 21:36

I doubt openMSX has anything to do with it. openMSX doesn't determine how much memory an MSX program uses (when using IDE). Can you give an example of such a program?

Por TheKid

Paragon (1080)

Imagen del TheKid

18-01-2021, 22:38

All of our programs using the philips music module suffer this problem, like all mega demos, thunderbirds are go promo (all can be downloaded on our site).

Por Manuel

Ascended (17460)

Imagen del Manuel

19-01-2021, 00:35

Are you sure they worked before with the same configuration? Because DOS2/Nextor and also Command2.COM may use extra memory. (By the way, didn't we have this conversation before? See https://www.msx.org/forum/msx-talk/openmsx/harddisk-image :))

Por gdx

Prophet (4017)

Imagen del gdx

19-01-2021, 02:20

Your problem is most likely caused by DOS2 / Nextor that reserves segments in the memory mapper. Try these soft under DOS1 ou Disk-Basic 1.xx.

Por TheKid

Paragon (1080)

Imagen del TheKid

19-01-2021, 06:41

@manuel:you are right, we did discus this earlier, but this time i am quite sure since back in the day, BiFi made a special fix for us so these programs would work on a cf or harddrive.

@gdx: does dos 1 support subdirectories?

Por Manuel

Ascended (17460)

Imagen del Manuel

19-01-2021, 08:24

No, it does not. If you want you can try older versions of course. But I'm pretty certain it's not an emulation issue.

Por sdsnatcher73

Paragon (1491)

Imagen del sdsnatcher73

19-01-2021, 09:12

It may not be emulation issue but possibly changes in config files could have resulted in changes (e.g. different ROM being used for the Sunrise IDE interface). Also which machine are you using together with IDE? This may also have seen changes.

If you send me the image file you are using I could test with different ROM versions/openMSX versions/MSX-DOS2 versions.

Por Grauw

Ascended (9568)

Imagen del Grauw

19-01-2021, 09:58

I think COMMAND2.44 uses more memory than COMMAND2.30, maybe that’s it?

Por TheKid

Paragon (1080)

Imagen del TheKid

19-01-2021, 12:24

did some more testing. Its version 2.20, but even without using command2.com and only basic, I still need 256kb.

Por TheKid

Paragon (1080)

Imagen del TheKid

19-01-2021, 13:26

I tried openmsx 9.1 with the same result. Did some more investigation and the fix i was talking about earlier, was not a memory fix but a turbo r fix. I am a little bit in shock but it seems all our programs that use music module, put on a harddisk or cf won’t work with stamdard 128 kb memory. So once again manuel is right and openmsx emulates correctly. (Sorry for that, won’t happen againSmile)
The only thing i don’t understand that evne if i don’t use command2.com, the progrmas still need 256 kb ?

Página 1/2
| 2