Symbian emulator?

Página 68/73
61 | 62 | 63 | 64 | 65 | 66 | 67 | | 69 | 70 | 71 | 72 | 73

Por jr

Champion (377)

Imagen del jr

06-10-2006, 19:42

If you're able to change the machine type (MSX1 -> MSX2 -> MSX2+) in the machine config menu then you have the files in the right location (not necessarily right files though). Make sure you don't have any of the other options from the machine config menu enabled unless you install ROMs for them as well. I'll try to find someone with an E61 to test the emu myself next week. Does the emulation work if you try it with no cartridges or disks? That should get you to MSX BASIC.

Por eleeot

Supporter (4)

Imagen del eleeot

07-10-2006, 07:28

I'd be glad to help in testing if you have some special rom for me to put into roms directory so i know what exact settings in the machine setup i should set. So please can you give me link for some rom for which i should choose for example MSX1?

Por jr

Champion (377)

Imagen del jr

09-10-2006, 16:37

Ok I was able to see this for real on an E61 device. The emulator does not actually crash or hang but there seems to be something that the E61 dislikes in the way I handle the display (which is a bit dodgy I admit -- but fast). If you press the pause button after pressing start (by default this is the "send" key) you should get to the pause menu and be able to exit the emulator normally. So the problem is "just" that the E61 refuses to display the screen. I'll try to investigate this a bit, I have two ideas. Unfortunately it will take some time before I can release a new version even if I find a solution quickly because I'm currently rewriting the whole rendering code of the emulator, I'm sorry.

Por eleeot

Supporter (4)

Imagen del eleeot

10-10-2006, 10:32

Ok I was able to see this for real on an E61 device. The emulator does not actually crash or hang but there seems to be something that the E61 dislikes in the way I handle the display (which is a bit dodgy I admit -- but fast). If you press the pause button after pressing start (by default this is the "send" key) you should get to the pause menu and be able to exit the emulator normally. So the problem is "just" that the E61 refuses to display the screen. I'll try to investigate this a bit, I have two ideas. Unfortunately it will take some time before I can release a new version even if I find a solution quickly because I'm currently rewriting the whole rendering code of the emulator, I'm sorry.

yes it behaves exactly as you say
i hope you will find a way! if i can help in testings please contact me, i'm open
jepp@ebrilo.com

Por Tbz

Supporter (4)

Imagen del Tbz

12-10-2006, 04:07

Hi jr!
Im new here, but id like to say that your work ip really appriceated. (uhm... correctly spelled? Tongue)

Ive just downloaded and installed the 1.13c msx emulator to my N80, and it seems to run just fine. But when i try to run a rom, my screen just turns black and nothing more happens.

The games im trying to emulate is: Metal Gear and Metal Gear 2: Solid Snake. (i read earlier that there was some problems with konami roms?)

And one more thing: could you please write a short guide that describes Step by Step from right after installing the emulator to when the rom is running smoothly? (with how to set up the different options, where to put the roms, etc.)

Thanks in Advance
Best Regards tbz

Por Tbz

Supporter (4)

Imagen del Tbz

12-10-2006, 04:22

Im sorry, 1.13d was of course the emulator i downloaded, not 1.13c.

Thanks again!

P.S.: I wrote these two post from my phone SmileSmile

Por [D-Tail]

Ascended (8259)

Imagen del [D-Tail]

12-10-2006, 06:48

P.S.: I wrote these two post from my phone SmileSmileGreat! Big smile

A silly question regarding your ROM loading: do you have the 'mapper' option set to 'auto'?

Por Tbz

Supporter (4)

Imagen del Tbz

12-10-2006, 14:34

Yes - the rom mapper ip set to auto.

But the thing is, i cant choose machine type or turn any of the other options on or off (except the 256 kb ram) in the machine setup menu.

Is there any simple explaination to this?

tbz

Por [D-Tail]

Ascended (8259)

Imagen del [D-Tail]

13-10-2006, 00:10

Yeah, well, you'd need the MSX1 or in the case of MG2, MSX2(+) system ROMs installed. Yahoo! around somewhere and I'm pretty sure you'll find them. Install them in the same way as you did fMSX/S60 or copy them into the desired directory on your phone.

[edit]For the extensions like MSXDOS2, RS232c, Kanji and a whole lot of other stuff, you'd need MSXDOS2.ROM, RS232.ROM and KANJI.ROM. All machine and extension stuff is ROM also Wink[/edit]

Por jr

Champion (377)

Imagen del jr

13-10-2006, 06:24

Indeed. It seems I forgot to add a check for this in the d version, I'll add it in the next release. That is, after the change you cannot start the emulation if you don't have any system ROMs installed Wink Anyway again a point in favor of having the system ROMs included with the emulator like some other emulators do, but...

Página 68/73
61 | 62 | 63 | 64 | 65 | 66 | 67 | | 69 | 70 | 71 | 72 | 73