Java MSX/MSX2 emulator with PSG/SCC/FM

Página 4/4
1 | 2 | 3 |

Por Manuel

Ascended (18392)

Imagen del Manuel

16-03-2009, 22:42

Got it working by switching to 32 bit again... (for some reason that works now?)

Well, more experiencies:
- Virtuarcade always runs in full screen
- sound doesn't work in any game
- I often get a message that there is no ROM image
- Java hung once blocking my sound device... :S Killing java unblocked it Smile

Por erikd

Master (255)

Imagen del erikd

17-03-2009, 01:22

Here it runs... but I tried playing Vampire Killer, and while the music was slower than normal, the player and enemy movement was waaaaay faster, making it almost impossible to play Sad

Hm, it runs at the speed that I remember it runs on.
Could it be that you're used to playing the game in 60Hz (it runs in 50Hz in JEmu2)? That could explain things, maybe...

- Virtuarcade always runs in full screen
true

- sound doesn't work in any game
- Java hung once blocking my sound device... :S Killing java unblocked it

Hmmm, did you see an error message anywhere? (on screen, or the java console?)
Most of the time when there are problems with JEmu2 it's on some Linux box for some reason. I dunno, I guess me and Linux don't get along very well Wink
What Linux distro do you use and what java version?
In any case, the Web Start version won't work on 64bit yet (I didn't include the 64 bit native binaries), but the applets should work on any platform with java 1.4 or higher. Well, if we can trust the 'write once run anywhere' mantra that is Wink (the applets are pure java, the web start version is not)

- I often get a message that there is no ROM image
Can you give an example of a game where that happens? I didn't test each and every game yet...

Thanks for testing everyone! Big smile

Por Manuel

Ascended (18392)

Imagen del Manuel

17-03-2009, 11:17

Oh, another thing: the games in Virtuarcade ran way too fast.

The distro shouldn't matter (but it's Debian) and I'm using Sun Java 6 update 12.

The applets did work on 64 bit, but no sound there either.

Most games I tried didn't have a ROM image... I'll list a few when I'm back home (and then I'll also check for error messages).

Por SLotman

Paragon (1238)

Imagen del SLotman

17-03-2009, 23:40

Yeah, just ran Nemesis 1 too, and it was also too fast... "almost as being played with turbo" fast... in some areas where there's little to update, it gets even faster, making it impossible to play (or at least impossible to survive heh).

Another problem (maybe corrupted ROM?) on Hinotori: I pressed F2 to get new weapon, and the graphics were corrupted as I moved the cursor left and right.

Por erikd

Master (255)

Imagen del erikd

18-03-2009, 13:28

The applets did work on 64 bit, but no sound there either.
Hm, maybe java doesn't like your sound drivers? Can you see anything in the java console?

Yeah, just ran Nemesis 1 too, and it was also too fast...
Strange.... Is that both in the applet and in the java web start versions? I tried them both at home and at work, and they work fine there Question

Another problem (maybe corrupted ROM?) on Hinotori: I pressed F2 to get new weapon, and the graphics were corrupted as I moved the cursor left and right.
heh, I never noticed that... My first guess is that it's not a corrupted ROM, but that I probably messed up somewhere Smile

Thanks again for testing!

Por Manuel

Ascended (18392)

Imagen del Manuel

18-03-2009, 14:04

I'm sorry, I couldn't get Java Console to work... I installed the plugin, but when I select "Java Console" in the menu, it gets grayed out and nothing happens otherwise... Sad

Por SLotman

Paragon (1238)

Imagen del SLotman

19-03-2009, 00:19

Here I was playing the browser version.

Por erikd

Master (255)

Imagen del erikd

19-03-2009, 11:00

Hm, yes the browser version does seem to have a problem on some PC's related to throttling.
On one laptop I saw it speed up to insane speeds and then sometimes slow down a bit, speed up etc.
I'll see what I can do about that. It still uses some old code that has some really weird workarounds for timing related bugs in the old microsoft VM, but I don't think anyone uses that anymore and I suspect these workarounds to cause the problem...

Por erikd

Master (255)

Imagen del erikd

19-03-2009, 11:04

manuel: It seems your PC and your JVM don't play nice together. I'm not sure what I can do about it... Maybe IBM's JVM works better on Linux?

Por erikd

Master (255)

Imagen del erikd

20-03-2009, 00:05

SLotman: I just changed something in the speed throttling in the applet. Could you give it another go when you find the time?

Página 4/4
1 | 2 | 3 |