After 3 days coding...

Page 3/5
1 | 2 | | 4 | 5

By Dolphin101546015

Rookie (27)

Dolphin101546015's picture

11-07-2018, 04:38

Sorry, it was my mistake, i forgot to set up you all first Smile
You just need set BG color = 1, and TX color = 15:
SCREEN 0:WIDTH80:COLOR 15,1,1
Here my test on real machine:

Thank you again :)

By max_iwamoto

Champion (384)

max_iwamoto's picture

11-07-2018, 04:54

Dolphin101546015 wrote:

Hello, friends!
A long time ago, i live in beautiful environment of MSX programmers such: Igor Bocharov, Alex Ryazanov, Alexey Zaiko, Evgeny Nosulich and many others.
Now, I got YAMAHA YIS-503-III as a gift, and want remember some tricks and features, also want upgrade it and apply several devices.

Good day, Sir.

You mention many interesting names. I am curious, did you know any of them personally? If you did, may I ask you which city are you from? I am also from over there, maybe we have met before...

---

Regarding the program, I made it work. On real MSX Russian or Turbo R it didn't work, but I think only because of the operation system - I used Nextor. On emulators, I had the same results until I use our own MSX-DOS that was designed for Yamaha MSX2.
If I run that, openMSX and Blue MSX works well. I didn't try real MSX with this OS, but I am pretty sure it will work. I am curious about what may cause the issue...

By max_iwamoto

Champion (384)

max_iwamoto's picture

11-07-2018, 05:01

Yes, you nailed it. After color 15,1,1 it works on real MSX as well. Nextor and all other starts as 15,4,4 I believe... And MSX DOS starts in screen 1 as well...

By Dolphin101546015

Rookie (27)

Dolphin101546015's picture

11-07-2018, 06:16

max_iwamoto wrote:

Good day, Sir.
You mention many interesting names. I am curious, did you know any of them personally? If you did, may I ask you which city are you from? I am also from over there, maybe we have met before...

Yes, i know all of them personally, and if you know my name, you will know me personally as well Wink
I am from Vladivostok city, and all this guys is my friends (less or more).
Also, not all of them is still alive, and still near me. Sad

By ToriHino

Master (206)

ToriHino's picture

11-07-2018, 06:54

Setting the right colors indeed solved the problem, also for the first version. The last version with autoset color works right away Cool

I do see that the width and positions of the bars is different on the Turbo R when the R800 mode is active. In R800 mode the bars move only half the screen and also have half the width as opposed to Z80 mode. Looks like the R800 is too fast and already completes before the next interrupt.

By Dolphin101546015

Rookie (27)

Dolphin101546015's picture

11-07-2018, 07:09

Sorry, i don't have an TurboR skills.
As i think, R800 will wait an VDP V- and H-retraces anyway.
No any interrupts used here, as well as not using BUSY VDP-flag.
Therefore, or R800 is too fast, and send commands to VDP wrong way (need some additional controls), or its just ignoring something.

By Dolphin101546015

Rookie (27)

Dolphin101546015's picture

12-07-2018, 21:45

By this message i will close my VDP experiment with last one video, coz i got all answers about perfomance of V9938 VDP.
But I still here and new experiments and demos coming soon. :)

By Pencioner

Hero (610)

Pencioner's picture

12-07-2018, 22:14

Nice, seems that i had no luck with first demo versions because i use non-standard colors by default too (Nextor starts with what you've set by SET SCREEN command though)

By ToriHino

Master (206)

ToriHino's picture

12-07-2018, 22:35

Dolphin101546015 wrote:

By this message i will close my VDP experiment with last one video, coz i got all answers about perfomance of V9938 VDP.
But I still here and new experiments and demos coming soon. :)

The video link is not working...

Page 3/5
1 | 2 | | 4 | 5
My MSX profile