Disabling cursor on screen 0 in ML ?


Paladin (864)

WORP3's picture

12-08-2016, 21:04

Hi there,
Maybe a stupid question but how can you disable the bios cursor on screen 0 ?
When I change the style then it's also changing but when I set SCRSW to zero it is still displaying, why Question

CSRY 0xF3DC /*Y-coordinate of cursor*/
CSRX 0xF3DD /*X-coordinate of cursor*/
CSRSW 0xFCA9 /*whether cursor is displayed (0 = no, otherwise = yes)*/
CSTYLE 0xFCAA /*cursor shape (0 = block, otherwise = underline)*/

Does anyone of you know how to switch it off ?

BTW I setting these variables before switching to screen 0 using the CHGMOD bios call.

Thanks in advance.

Login or register to post comments


Paladin (864)

WORP3's picture

12-08-2016, 21:15

Already found it. For some reason my intel was wrong.
SRSW 0=cursor is displayed
SRSW 1=cursor is not displayed

Thanks anyway Big smile

By AxelF

Champion (395)

AxelF's picture

12-08-2016, 21:36

I think you mean:
FCA9 CSRSW cursor display switch...