Turbo-R GT + MegaFlashRom SCC+ SD + DenyoNet = crash at boot?

Page 4/7
1 | 2 | 3 | | 5 | 6 | 7

By edoz

Prophet (2172)

edoz's picture

29-01-2014, 12:27

Oeps: Question .. I was switching rom's, but during the procedure there was something going wrong.

I typed the current syntax: (where my DenyoNet was in slot 1)

denyorom denyotcp.rom 1 /mac:00-50-c2-e4-50-12

Output:

> erasing flash memory block 0 ... OK
> Writing flash memory ERROR!!

** Failed to write on the flash memory

At the moment my DenyoNet is not detected at boot anymore and I'm not able to flash again...
Any suggestions ?

By Latok

msx guru (3685)

Latok's picture

29-01-2014, 12:54

edoz, I've had the same errors as you describe. Erasing flash memory block 0 ... ok and then Writing flash memory ERROR!!

After this, I couldn't do anything with DenyoNet anymore on my turboR GT. Then I inserted DenyoNet in slot 1 of my NMS8245 MSX2 and flashed it from floppydisk in DOS2....

That worked....

Yes, it was scary ^___^

By edoz

Prophet (2172)

edoz's picture

29-01-2014, 13:10

Nope..(I have no 8245) but on my MSX 8280 I'm not able to flash it again. Same error. Tried DOS2 and DOS1. In slot 1 and 2 .. (from floppy)
same results.. so it seems my Denyonet is broken now ?

By edoz

Prophet (2172)

edoz's picture

29-01-2014, 13:33

Good news!! It seems, my MSX8280 (2+) 7mhz/3.5 mhz was not working. So I wend to my attic where my private spares are based Big smile
I found a normal 8280 and I was able to flash it again! ... so solved for now Wink

By konamiman

Paragon (1044)

konamiman's picture

29-01-2014, 14:25

Flashing the DenyoNet ROM is somewhat tricky.

I had the same problem too using a NMS8245... which disappeard when I put a lego piece under the cartridge (which was standing horizontally, in slot 2) in order to compensate the angle caused by its own weight, and which apparently was causing a bad connection with the slot pins.

One certainly must be a bit of a McGyver to own a MSX... Smile

By edoz

Prophet (2172)

edoz's picture

29-01-2014, 15:24

ducktape Big smile

By Latok

msx guru (3685)

Latok's picture

29-01-2014, 17:40

konamiman wrote:

...which disappeard when I put a lego piece under the cartridge (which was standing horizontally, in slot 2) in order to compensate the angle caused by its own weight, and which apparently was causing a bad connection with the slot pins

This makes my day Big smile MSX is awesome!!

By Grauw

Ascended (8451)

Grauw's picture

29-01-2014, 17:51

The power of lego!

By konamiman

Paragon (1044)

konamiman's picture

30-01-2014, 17:10

Ok people... brace yourselves because it's BETATESTING TIME!



All of you having a DenyoNet (and especially, having a DenyoNet and a Turbo-R GT!) please be so kind to download this and try it. It is a zip file containing the following:

  • DENYOTCP.ROM: A new version (0.6) of the DenyoNet TCP/IP BIOS. It corrects a bug (due to me reading an outdated version of the W5100 datasheet, aaaargh!) that caused a status of "Connection closed" to be reported when the actual status was "Performing ARP resolution". It still has the GT bug but continue reading.
  • DENYTCP2.ROM: An alternative version of the BIOS that has the meaning of the ESC key reversed: the BIOS is NOT initialized when the key is NOT pressed.
  • DENYINIT.COM: A command line tool that initializes the DenyoNet TCP/IP BIOS. Usage: DENYINIT denyonet_slot[-subslot]

So if you have a GT the strategy is: flash DENYTCP2.ROM in your DenyoNet, then put DENYINIT.COM in your autoexec.bat to activate it at boot time. (You can do that too if you don't have a GT, but it's unnecessary as the regular ROM will work fine)

If a couple of persons confirm me that this works, I'll upload it to my web site, together with the new version of MSX trivial dropbox.

By karloch

Prophet (2065)

karloch's picture

30-01-2014, 18:38

Yipieeeee!!! Let me reach $HOME and I'll give a try Smile

Page 4/7
1 | 2 | 3 | | 5 | 6 | 7