AX-230 photos/ROMs - How to update WiKi and BlueMSX?

Page 2/6
1 | | 3 | 4 | 5 | 6

By Manuel

Ascended (14996)

Manuel's picture

13-06-2018, 07:36

Are you sure? The casing says clearly 64kB.

You can dump all slots with saverom.com. try testram.com as well, perhaps.

By gdx

Prophet (2479)

gdx's picture

13-06-2018, 09:05

Sure, the AX230 has 64kB. We can see the two DRAM (2 x HM50464P-12) on the board.

http://pdf.icpdf.com/PdfOld/icpdf_datasheet_7/HM504_datashee...

In extra, there is a SRAM of 32kB probably for a function to discover.

The slot map also seems false. MSX Cartridge slots should be primary according to the standard.

By Tabajara-Labs

Expert (90)

Tabajara-Labs's picture

13-06-2018, 09:14

The 2 64K chips are connected to the video ram bus on the msx engine. The PSRAM is connected to the user RAM bus.

The slot map is wrong on slot 2 because I'm using a SD Mapper to run MSXMEM

By Tabajara-Labs

Expert (90)

Tabajara-Labs's picture

13-06-2018, 09:15

Where in the casing is written 64K? Smile
Also, I don't remember if testram recognizes just 32K on a machine, will test on a YIS303

By gdx

Prophet (2479)

gdx's picture

13-06-2018, 09:52

MSX1s have 16KB of VRAM not 64kB. The VDP and its VRAM is integrated in the T7937A.

By mars2000you

Enlighted (5413)

mars2000you's picture

13-06-2018, 11:42

Changed the map on the Wiki. The Games ROM is in slot 3-1, 3-2 or 3-3, it needs to be checked with saverom. It's probably slot 3-3 if we compare with AX-170, as it is the place of the second cartridge slot, that has been removed on the AX-230.

This 1024kB ROM has the ASCII8 mapper. It can't work without the presence of an Arabic ROM in the MSX computer.

The other dump (128kB) can be divided as follows:
- first 32 KB = BIOS rom
- next 32 KB = Arabic ROM with inversion of the 16kB blocks (AB signature is not at the beginning of this 32kB block)
- next 64 kB = empty

By gdx

Prophet (2479)

gdx's picture

13-06-2018, 12:00

VRAM is not integrated into T7937A but its pins for VRAM are connected to IC130 (a 74AHCT373P?) and this one towards the IC129 (the SRAM). VRAM is in the SRAM. Maybe they put 32kb instead of 16k for cost reasons. Sometimes the 32k are cheaper than the 16k.

By Manuel

Ascended (14996)

Manuel's picture

13-06-2018, 13:38

Tabajara-Labs wrote:

Where in the casing is written 64K? Smile

At the top left it says: AX230 64K RAM PERSONAL COMPUTER

Quote:

Also, I don't remember if testram recognizes just 32K on a machine, will test on a YIS303

It will, but you will need to disable the RAM in the cartridge you're using (or use a normal external floppy drive).

By Manuel

Ascended (14996)

Manuel's picture

13-06-2018, 13:42

mars2000you wrote:

Changed the map on the Wiki. The Games ROM is in slot 3-1, 3-2 or 3-3, it needs to be checked with saverom.

Yep, awaiting the 64k dumps of all slots to know where things are exactly.

Quote:

It's probably slot 3-3 if we compare with AX-170, as it is the place of the second cartridge slot, that has been removed on the AX-230.

Possibly.

Quote:

This 1024kB ROM has the ASCII8 mapper. It can't work without the presence of an Arabic ROM in the MSX computer.

OK. So we just need the slot location.

Quote:

The other dump (128kB) can be divided as follows:
- first 32 KB = BIOS rom
- next 32 KB = Arabic ROM with inversion of the 16kB blocks (AB signature is not at the beginning of this 32kB block)
- next 64 kB = empty

And that Arabic ROM is mapped where? Slot 1-0? Well, the 64k dump will tell us.

By Manuel

Ascended (14996)

Manuel's picture

13-06-2018, 14:05

With the current assumptions, I'm getting things at least to work, thanks to all of you. Well, most of it.

From the start menu, I see strange behaviour, when pressing the numbers:
1. resets and goes back to the menu...?
2. Gives "Undefined line number in 10" error. Clearly something is wrong.
3. goes to BASIC
4. also goes to BASIC
5. gives a menu with educational games in Arabic
6. gives a menu with Aackosoft arcade games
7. goes to BASIC

From BASIC, if I do _MENU, I get a shorter menu with 5 items:
1. resets and goes to the first menu
2. resets and goes to the first menu
3. resets and goes to the first menu
4. resets and goes to BASIC
5. resets and goes to BASIC

So, something is not right. I'm not getting the calendar and other utilities. What could be wrong?

Also, is there something with persistent SRAM somewhere? Or was that a mistake?

Page 2/6
1 | | 3 | 4 | 5 | 6
My MSX profile