Metal Gear 2 MSX emulation speed?

Page 1/6
| 2 | 3 | 4 | 5 | 6

By Muyfa666

Resident (36)

Muyfa666's picture

10-06-2020, 15:59

Hi fellas.

I've been trying on and off to get MG2 running at smooth playable speed, but I cannot seem to get it right.

No matter what emulator I use, the game is choppy in the controls sort to speak.

What is required for this to work properly?

I noticed that online version Jamsx runs very nice. How is that possible?

Login or register to post comments

By Manuel

Ascended (16700)

Manuel's picture

10-06-2020, 19:38

Which emulators did you try?
Which version of the game did you use?
On which hardware and OS were you running these emulators?
Did you use the same hardware and OS for the JavaMSX run? (If that's what you mean with Jamsx.)

By Ivan

Ascended (9181)

Ivan's picture

10-06-2020, 20:26

Use an MSX emulator that supports MSX TurboR (last generation of MSX) and hold the shift key while booting. You will play it in R800 mode. Smooth and fast as it can be!

By Randam

Paladin (969)

Randam's picture

10-06-2020, 21:15

Or use FRS's turbo patch and play it on a turbo R.

By Muyfa666

Resident (36)

Muyfa666's picture

11-06-2020, 21:55

I'm using openMSX. Can't really get TurboR to work in that one thou, or much of anything else... ;-)

I tried Retroarch and it works kind of of there, but I'd rather have it run good in openMSX.

By Manuel

Ascended (16700)

Manuel's picture

11-06-2020, 21:59

Well, let's fix that. What is the problem exactly getting a turboR to run?
Please also answer:
- Which version of the game did you use?
- On which hardware and OS were you running openMSX?
- Did you use the same hardware and OS for the JavaMSX run? (If that's what you mean with Jamsx.)

By Muyfa666

Resident (36)

Muyfa666's picture

11-06-2020, 22:33

Manuel wrote:

Well, let's fix that. What is the problem exactly getting a turboR to run?
Please also answer:
- Which version of the game did you use?
Metal Gear 2 - Solid Snake (1990) (Konami) (J).mx2 (GoodMSX) with English patch and turbo patch.
- On which hardware and OS were you running openMSX?
MacOS, MBP13 2020 gen10 i5.
- Did you use the same hardware and OS for the JavaMSX run? (If that's what you mean with Jamsx.)
Yes.

By Muyfa666

Resident (36)

Muyfa666's picture

11-06-2020, 22:35

I have a hard time getting my head around how bios:es work with openMSX.

By Manuel

Ascended (16700)

Manuel's picture

11-06-2020, 23:07

See Grauw's comment here: https://www.msx.org/forum/msx-talk/openmsx/please-help-testi... That should fix that!

By Muyfa666

Resident (36)

Muyfa666's picture

11-06-2020, 23:28

Thanks! The hidden stuff seem to work.
However, when I try to use openMSX Team Boosted MSXturboR, I get memory error.
Should I use something else?

By Manuel

Ascended (16700)

Manuel's picture

12-06-2020, 00:06

Just use a Panasonic FS-A1ST or GT. That's a standard turboR.

Page 1/6
| 2 | 3 | 4 | 5 | 6