OpenMSX 0.12.0 Reverse not recording.

Page 2/3
1 | | 3

By Huey

Prophet (2675)

Huey's picture

26-03-2016, 22:35

By Manuel

Ascended (18233)

Manuel's picture

26-03-2016, 22:36

That's the latest 0.12.0 release, not the latest development build. Please try the latest development build on http://openmsx.fixato.net/builds/windows/x64/

By Huey

Prophet (2675)

Huey's picture

26-03-2016, 22:48

Ill test iT Tomorrow asap

By Manuel

Ascended (18233)

Manuel's picture

26-03-2016, 22:50

OK, if it still gives the problem, please save the replay and send me the file, then I'll take a look at what was interrupting the replay.

By Huey

Prophet (2675)

Huey's picture

27-03-2016, 11:55

Goodmorning Manuel,
The latest development build solved the issue. Thanks for the help.

Now for some egg bug hunting on easter. Wink

By Manuel

Ascended (18233)

Manuel's picture

27-03-2016, 12:00

Good to hear that. I guess we should create a new release soonish.

Are there any other critical issues that should be fixed before we can release?

By ~mk~

Champion (303)

~mk~'s picture

27-03-2016, 15:40

I'm having trouble typing the double quotation marks with the latest version, e.g. to type bload"file",r
When emulating a Talent TPC-310 I get: bload""ile""r
When emulating a Sanyo PHC-23JB I get: bload*"ile*"r

Sounds like a bug because with an older version it didn't happen.
My keyboard is english (US) and I have to type SHIFT+' to get ".
Whenever I send that key code to openMSX it outputs either " or *, and the next key, whichever it is, comes out as ".

Bug or something wrong with my setup?

By Manuel

Ascended (18233)

Manuel's picture

27-03-2016, 15:58

Looks like keyboard problems in SDL again... Do you have your keyboard settings of your OS set to "US International"? That is known to give problems.

I don't think it's a bug, as we didn't change anything to the keyboard driver in years. I wonder which version worked for you before.

By Grauw

Ascended (10137)

Grauw's picture

27-03-2016, 16:12

Got the same issue on my Mac with OS X 10.11.3 and US (International) keyboard layout, however it’s a long existing problem and nothing changed recently.

By AxelF

Champion (389)

AxelF's picture

27-03-2016, 16:40

Same problem here in windows,
Mostly i can solve it by exiting OpenMSX and after that
tapping [CTRL] + [Shift] keys a few times
This shortkey switches between the 2 keyboard languages.

Page 2/3
1 | | 3