openmsx can't find game ROMs

By Shinobi

Master (198)

Shinobi's picture

26-01-2018, 20:05

Hi..

After trying for several weeks in LAKKA and Retropie, trying BlueMSX and fMSX to launch Arabic machines like AX170 to run some Arabic educational software, it just didn't work, fMSX didn't have the capabilities and BlueMSX in Lakka and Retropie seems hard wired and tailored to generic MSX,MSX2,MSX2+ and turbo MSX (all in english and pure not to Brazil or Arabic countries or any other nationality) ..

I tried openmsx in Raspbian (in Raspberry pi) succeeded to launch AX170 and AX350IIF machines, I put the systems ROMs in their folder under openmsx/share/systemroms/, as I read here and there, Game ROMS (non-system-roms) must be in openmsxs/share/software/ so that I can launch them by typing "carta 1942.ROM" for example.

Now my problem is that openmsx seems not being able to find game ROMs, when I type carta 1942.ROM or cart insert 1942.ROM to launch the game, it say "can't find rom in the context", I tried other ROMs other than 1942.ROM like Actman.rom, and taking into consideration the case of the letters, and I got no result.
What's wrong in this case??

Login or register to post comments

By rderooy

Paladin (686)

rderooy's picture

26-01-2018, 20:27

If your launching openmsx from the commandline, did you try just having the game ROM files in your current (working) directory?

In any case, if your using retropie the game ROM files should normally be in a specific location, such that emulationstation can find and index them. You then need to tell retropie to use openmsx as your default MSX emulator.

By turbor

Champion (488)

turbor's picture

26-01-2018, 22:01

Given that you talk about typing 'carta 1942.ROM' and 'cart insert 1942.ROM' I'm assuming that you tried that from the openMSX console (pressing F10 when openMSX runs), and not the command line when you started openMSX?

If so you can use the bash-like completion after you have typed 'cart insert' to specify the full-path towards the 1942 rom file. If you give full-path names then openmsx doesn't need to guess where to roms are located.

you can do this on the CLI also: 'openmsx -machine Al_Alamiah_AX370 -carta /path/to/the/file/1942.ROM '

Also, as you might already have found out: Linux uses a case sensitive filesystem. So upper and lowercase characters are different. If you use windows explorer to change the filenames from upper to lower case or vice versa via a samba share on your retropie, then this might fail. The cases shown in internet explorer aren't always the actual filenames on the linux disk...

By Manuel

Ascended (18238)

Manuel's picture

27-01-2018, 00:38

Indeed, openMSX only searches in these folders by sha1sum (e.g. referred to from the hardware configuration XML file or from a saved replay). If you want to launch a game (by filename) you'll have to specify the full path. And yes, hitting TAB is very helpful there Smile You can also browse with the built in OSD menu.

By Shinobi

Master (198)

Shinobi's picture

27-01-2018, 01:43

Fullpath was the solution. Thanks all.