OpenMSX debugger: Bitmapped VRAM viewer

By jltursan

Prophet (2145)

jltursan's picture

10-09-2019, 15:27

I'm not able to make it work, no matter the VDP model or enabled mode, all I get is a screen full of garbage. I'm running the Windows version of the GUI debugger and I haven't found any info related to this; but seems a really straightforward feature so I don't think that I'm doing something wrong.

Note that I'm using the GUI, I'm sure that using "debug read_block " over VRAM debuggable will work...

Has anyone used this cool feature and can share some knowledge?

Login or register to post comments

By Grauw

Ascended (8309)

Grauw's picture

10-09-2019, 15:33

I’m using it at several points in the first half of this video: https://youtu.be/nOg4X92f7os

By Manuel

Ascended (15600)

Manuel's picture

10-09-2019, 22:22

Yep, should work fine. Which version are you using of the openMSX Debugger GUI, jltursan, and on which OS?

By max_iwamoto

Champion (464)

max_iwamoto's picture

11-09-2019, 02:57

Sometimes you need to open bitmapped VRAM twice at the beginning to show the correct picture. But for me 1st run doesn't show garbage, usually just black.

By Grauw

Ascended (8309)

Grauw's picture

11-09-2019, 08:06

If it's black try toggling the use palette checkbox twice.

By jltursan

Prophet (2145)

jltursan's picture

11-09-2019, 12:10

Here's mine (Windows 10 Pro x64):

This garbage is what I usually get
OpenMSX is version 0.15.0. The debugger is snapshot openMSX_Debugger_x64_20180220.

I'm emulating a HB-75P. At first I thought that it only works with MSX2 or greater machines as unchecking "Use current VDP settings" doesn't offer MSX1 modes; but I tested it with some MSX2 programs without success.
I haven't tested any other emulated machine, maybe it's related to its configuration.

@Grauw: yep, yours is working fine, with manual settings but fine. You're emulating a GT machine, I'll try with it.

By Manuel

Ascended (15600)

Manuel's picture

11-09-2019, 13:08

The Bitmap viewer only supports bitmapped modes...

By jltursan

Prophet (2145)

jltursan's picture

11-09-2019, 13:39

Doh!, that explains why SC4 doesn't appears. Bad luck, by some reason I was expecting something like the one in Meisei Sad

Thanks for clarifying this!

By Manuel

Ascended (15600)

Manuel's picture

11-09-2019, 17:43

Patches to add this are of course most welcome Smile