OpenMSX: Not enough free cartridge slots

By Metalion

Paragon (1451)

Metalion's picture

31-01-2021, 14:45

Hello,

I'm trying to start a configuration on OpenMSX with:
- an MSX computer with 2 slots
- a MegaFlashRom SCC+ SD
- an SFG-01/05 extension

But whatever the one I choose, I always get a "Not enough free cartridge slots" message.
Which is not logical (captain Wink ), since this configuration only needs 2 slots.

What's happening ?

Login or register to post comments

By turbor

Champion (488)

turbor's picture

31-01-2021, 15:43

Which is the exact machine you are using? Not all machines have 2 slots available for the end user.

By Metalion

Paragon (1451)

Metalion's picture

31-01-2021, 16:44

Metalion wrote:

I'm trying to start a configuration on OpenMSX with:
- an MSX computer with 2 slots
...

As I said, I'm choosing machines with 2 slots : Sony HB-F700F, Philips NMS-8245, ...

By lintweaker

Champion (417)

lintweaker's picture

31-01-2021, 16:50

In what slot(s) did the MegaFlashROM SCC+SD go?

By Metalion

Paragon (1451)

Metalion's picture

31-01-2021, 17:09

lintweaker wrote:

In what slot(s) did the MegaFlashROM SCC+SD go?

AFAIK, OpenMSX does not let you choose that.
So I do not know.

This is what I get with a Sony HB-F700F:

By Metalion

Paragon (1451)

Metalion's picture

31-01-2021, 17:21

OK, I found the problem : I had 2 copies of the SFG-05 rom in the systemroms folder.
Keeping only 1 solved the issue.

By Manuel

Ascended (18247)

Manuel's picture

31-01-2021, 19:10

That makes no sense, it has no influence on filling up cartridge slots.

Anyway, try using the OSD menu. You are using the latest development build, in which you can exactly specify what gets in which slot.

By Manuel

Ascended (18247)

Manuel's picture

01-02-2021, 19:39

So, I think you still had some other extension inserted instead.

By Metalion

Paragon (1451)

Metalion's picture

02-02-2021, 08:22

Manuel wrote:

So, I think you still had some other extension inserted instead.

No, Manuel, I can assure you that there was no other extension inserted except for the MFR SCC+ SD and the SFG-05. I checked multiple times, and with different machines !

And I know you said it does not make sense, but the problem was solved when I removed an extra copy that was in the "share" folder. Actually, there was 2 copies : one zipped, and one unzipped, both downloaded from the hansotten website. And a third one in the "systemroms" folder (the normal one).

But I must say that I tried to reproduce the defect afterwards, without success.