WebMSX Release 5.0 - NetPlay! - Nextor Hard Drive - Turbo 8x

Page 4/4
1 | 2 | 3 |

By Manuel

Ascended (14320)

Manuel's picture

13-05-2018, 00:44

ppeccin: OK, thanks for explaining that! Smile Are you satisfied (still) with this choice?

By ppeccin

Champion (332)

ppeccin's picture

14-05-2018, 17:37

Well, I don't have tons of feedback regarding NetPlay performance.
But on the tests I did, it worked pretty decently... Of course, it will always depend on the network quality (mainly latency), as any network game. Do you have any feedback or had any problem you would like to share?

So yes! As of now I am (still) satisfied! Big smile

By Manuel

Ascended (14320)

Manuel's picture

14-05-2018, 17:55

I only tried once, but that seemed to work quite ok.

By ppeccin

Champion (332)

ppeccin's picture

15-05-2018, 06:37

Nice to hear that! ☺️

By mfeingol

Master (252)

mfeingol's picture

20-05-2018, 02:35

@ppeccin:

I just gave NetPlay a try using two machines on my LAN, and I wasn't able to get the second client to connect. It basically says "Establishing connection..." forever and the second client never syncs up the MSX state with the first client.

Is it possible the server is using IP addresses to identify clients, and therefore this won't work well with two clients coming from inside the same LAN?

Thanks.

By ppeccin

Champion (332)

ppeccin's picture

20-05-2018, 03:46

mfeingol wrote:

@ppeccin:
I just gave NetPlay a try using two machines on my LAN, and I wasn't able to get the second client to connect. It basically says "Establishing connection..." forever and the second client never syncs up the MSX state with the first client.
Is it possible the server is using IP addresses to identify clients, and therefore this won't work well with two clients coming from inside the same LAN?
Thanks.

Well, I did almost all my testing in the same scenario, and on much worse situations, and it always worked. But the mechanism may fail depending on the router/firewall blocks you have. Its is uncommon, but If it is too restrictive, it may fail. What machines/SOs/browsers/versions? Can you send me the Javascript console messages of both machines?

By mfeingol

Master (252)

mfeingol's picture

20-05-2018, 21:19

@ppeccin:

I did a little more testing and it looks like the problem is actually Microsoft Edge. I'm able to connect using two side-by-side tabs in Chrome, but it doesn't work if one of the browsers is Edge. This is on Windows 10 (17134.48).

The error in the console is: SCRIPT438: Object doesn't support property or method 'createDataChannel'

By ppeccin

Champion (332)

ppeccin's picture

23-05-2018, 19:27

mfeingol wrote:

@ppeccin:
I did a little more testing and it looks like the problem is actually Microsoft Edge. I'm able to connect using two side-by-side tabs in Chrome, but it doesn't work if one of the browsers is Edge. This is on Windows 10 (17134.48).
The error in the console is: SCRIPT438: Object doesn't support property or method 'createDataChannel'

Oh, yes, that makes sense... I didn't even test on Edge.
It probably does not support one of the technologies I use (WebRTC).

So you better stick with Chrome, or as a second preference, Firefox.

Page 4/4
1 | 2 | 3 |
My MSX profile