WebMSX running SymbOS!

Page 1/5
| 2 | 3 | 4 | 5

By ppeccin

Champion (344)

ppeccin's picture

20-05-2018, 03:56

Online at: http://webmsx.org/symbos

Drivers available at the project homepage.

Paulo

Login or register to post comments

By abslide

Rookie (32)

abslide's picture

20-05-2018, 08:43

Thank you!

By Manuel

Ascended (15837)

Manuel's picture

20-05-2018, 08:56

I started Pacman, and the CPU usage almost didn't go up. Then I noticed the CPUx4 at the bottom... hmm. That explained. Why is it x4 by default?

By abslide

Rookie (32)

abslide's picture

20-05-2018, 10:26

Does not sound support? When I run SymAmp, there is no sound.

By karloch

Prophet (2067)

karloch's picture

20-05-2018, 11:44

Great work! Although I am having a hard time locking the mouse on the screen Smile

By abslide

Rookie (32)

abslide's picture

20-05-2018, 15:10

How do I create symbos.ini after installation? I think I made a new one. After installing as an install file, WebMSX driver file move to symbos directory, after setting the floppy and hard disk with symsetup, it will not work after sym command. So I copied the symbos.ini made in WebMSX and moved it. That's it. I deleted symbos.ini and it does not work. I wonder how to create symbos.ini?

By ppeccin

Champion (344)

ppeccin's picture

20-05-2018, 17:51

Quote:

I started Pacman, and the CPU usage almost didn't go up. Then I noticed the CPUx4 at the bottom... hmm. That explained. Why is it x4 by default?

I think it should be 3x not 4x.
The /symbos page is just a shortcut to demo SymbOS. It sets some parameters automatically, and its using WebMSX MSX2++ machine, which is just a normal MSX2+ with some boosts: 1024 RAM, Nextor and 3x Turbo active.

The /symbos shortcut also sets a wider AspectRatio, and sets the Mouse mode to AUTO.

By ppeccin

Champion (344)

ppeccin's picture

20-05-2018, 17:39

karloch wrote:

Great work! Although I am having a hard time locking the mouse on the screen Smile

Middle Mouse Button locks the pointer to the emulator screen. Its on the Help Dialog... Ins't it working for you?

By ppeccin

Champion (344)

ppeccin's picture

20-05-2018, 17:41

abslide wrote:

Does not sound support? When I run SymAmp, there is no sound.

Is SymAmp supported on MSX? Even more, is sound even supported on SymbOS under MSX???

I read somewhere sound is not yet supported on MSX. Does anybody know whether we should or not get sound under MSX?

By ppeccin

Champion (344)

ppeccin's picture

20-05-2018, 17:47

abslide wrote:

How do I create symbos.ini after installation? I think I made a new one. After installing as an install file, WebMSX driver file move to symbos directory, after setting the floppy and hard disk with symsetup, it will not work after sym command. So I copied the symbos.ini made in WebMSX and moved it. That's it. I deleted symbos.ini and it does not work. I wonder how to create symbos.ini?

I don't know exactly, but when I install SymbOS on WebMSX, I must first un-select all detected devices, then add 2 devices (press "U"), first the Floppy driver, then the HD driver. Set the boot partition accordingly, and it works.

IMPORTANT: The problem is that the SymbOS package does not include WebMSX drivers (yet). So you have to first create the \SYMBOS directory manually, and copy both driver files there (-FDWMSX.DRV and -HDWMSX.DRV). Then the install program SYMSETUP will find and allow you to use them.

If you use the link provided that goes to Symbos directly, you can then save the HardDisk image file, with everything already installed.

By karloch

Prophet (2067)

karloch's picture

20-05-2018, 18:39

ppeccin wrote:
karloch wrote:

Great work! Although I am having a hard time locking the mouse on the screen Smile

Middle Mouse Button locks the pointer to the emulator screen. Its on the Help Dialog... Ins't it working for you?

I didn't know, working like a charm, thank you! Smile

Page 1/5
| 2 | 3 | 4 | 5