help openmsx debugger

Page 1/3
| 2 | 3

By PingPong

Prophet (3093)

PingPong's picture

20-02-2018, 00:35

Hi, all having trouble with openmsx debugger
i start openmsx and i see the socket.pid file on C:\Users\\AppData\Local\Temp\openmsx-
when i run the openmsx debugger i cannot connect because the debugger do not see any session.

working on windows 7
any idea?

Login or register to post comments

By wilsonpilon

Champion (266)

wilsonpilon's picture

20-02-2018, 12:59

Hi, you check for any zombie openmsx process or orphaned socket file?
Can you communicate with openmsx through socket.pid (via SOCAT and NETCAT Windows versions)?
Try to clear any file in %USER%/AppData/Local/Temp/openmsx-default and %USER%/AppData/Local/Temp/openmsx before start the openmsx and debugger.

cheers!

By PingPong

Prophet (3093)

PingPong's picture

20-02-2018, 21:01

wilsonpilon wrote:

Hi, you check for any zombie openmsx process or orphaned socket file?
Can you communicate with openmsx through socket.pid (via SOCAT and NETCAT Windows versions)?
Try to clear any file in %USER%/AppData/Local/Temp/openmsx-default and %USER%/AppData/Local/Temp/openmsx before start the openmsx and debugger.

cheers!

i think this is not the problem. on the active sessions i cannot get any entry listed.
no zombie files on folder.
i can successfully telnet to the port openmsx has stored in the socket.pid file.
openmsx version 0.14.187-<> release
debugger version ---------------------------
openMSX Debugger 0.10.0-258-g85db7c3

By Manuel

Ascended (14327)

Manuel's picture

20-02-2018, 21:12

Is that indeed the latest debugger binary?

By PingPong

Prophet (3093)

PingPong's picture

20-02-2018, 21:14

Manuel wrote:

Is that indeed the latest debugger binary?

i do not know.... where i can verify/download the latest binary version?

By Manuel

Ascended (14327)

Manuel's picture

20-02-2018, 22:11

Good question, it's a bit of a mess. But you could try this one: http://openmsx.fixato.net/builds/windows/x64/debugger/openms... Let me know if that works better.

By hit9918

Prophet (2750)

hit9918's picture

20-02-2018, 23:34

"windows defender smartscreen" says that the debugger is evil.
I had the same problem a year ago and then did nothing.
does anyone know whether maybe smartscreen is a joke?

the german text says
"the start of an unknown app was hindered"
"under circumstances a risc"
both is a joke
still I dont dare to click

By Manuel

Ascended (14327)

Manuel's picture

20-02-2018, 23:56

It only warns that the program wasn't signed, I think... Didn't it say the same for openMSX itself?

I would just trust it myself :-)

By FiXato

Scribe (1434)

FiXato's picture

21-02-2018, 20:32

This should be the most recent debugger for Windows x64: http://openmsx.fixato.org/builds/windows/debugger/openMSX_De...

(Thanks for Vampier, of course)

By PingPong

Prophet (3093)

PingPong's picture

21-02-2018, 20:33

FiXato wrote:

This should be the most recent debugger for Windows x64: http://openmsx.fixato.org/builds/windows/debugger/openMSX_De...

(Thanks for Vampier, of course)

does not work

By Manuel

Ascended (14327)

Manuel's picture

21-02-2018, 21:57

Can you be more specific? Do you mean it behaves the same as described in your first post?
I don't know what it is though, I didn't hear complaints from other people, so there must be something local on your PC that influences this. Firewall software perhaps?

Page 1/3
| 2 | 3
My MSX profile