help openmsx debugger

Page 2/3
1 | | 3

By PingPong

Prophet (3093)

PingPong's picture

22-02-2018, 00:33

Manuel wrote:

Can you be more specific? Do you mean it behaves the same as described in your first post?
I don't know what it is though, I didn't hear complaints from other people, so there must be something local on your PC that influences this. Firewall software perhaps?

Same problem as reported earlier. At this point i need some time to build/try/debug the issue on my machine.
It is almost clear that something is failing when reading the socket.pid file.

What i do not know is the effort needed to build from sources the binary on a windows machine.
here i have msvc installed and i can also try with the gcc toolchain.
but i need some time to try to build the binary.

Before this i can also try with a file monitor utility that trace all file I/O calls and report me issues like 'EPERM' or not found .

By PingPong

Prophet (3093)

PingPong's picture

22-02-2018, 01:04

update, from what i can read the process is successfully accessing the socket.pid file and reading the contents, the port number, 9990. I've also tryed a telnet on this port, it is connecting:

01:00:07,0333798	openmsx-debugger.exe	5868	CreateFile	C:\Users\DEFAULT.DEFAULT-PC\AppData\Local\Temp\openmsx-default\socket.9672	SUCCESS	Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, AllocationSize: n/a, OpenResult: Opened
01:00:07,0334362	openmsx-debugger.exe	5868	ReadFile	C:\Users\DEFAULT.DEFAULT-PC\AppData\Local\Temp\openmsx-default\socket.9672	SUCCESS	Offset: 0, Length: 6, Priority: Normal
01:00:07,0633426	openmsx-debugger.exe	5868	CloseFile	C:\Users\DEFAULT.DEFAULT-PC\AppData\Local\Temp\openmsx-default\socket.9672	SUCCESS	
01:00:09,4737418	openmsx-debugger.exe	5868	CreateFile	C:\Users\DEFAULT.DEFAULT-PC\AppData\Local\Temp\openmsx-default\socket.9672	SUCCESS	Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, AllocationSize: n/a, OpenResult: Opened
01:00:09,4737847	openmsx-debugger.exe	5868	ReadFile	C:\Users\DEFAULT.DEFAULT-PC\AppData\Local\Temp\openmsx-default\socket.9672	SUCCESS	Offset: 0, Length: 6, Priority: Normal
01:00:09,4850524	openmsx-debugger.exe	5868	CloseFile	C:\Users\DEFAULT.DEFAULT-PC\AppData\Local\Temp\openmsx-default\socket.9672	SUCCESS	

By Manuel

Ascended (14327)

Manuel's picture

22-02-2018, 07:36

It should at least build with Visual Studio indeed.

By Vampier

Prophet (2155)

Vampier's picture

22-02-2018, 19:26

works for me

By PingPong

Prophet (3093)

PingPong's picture

24-02-2018, 18:54

hi, using vs2015. i've cloned into /op the contents and opened the .sln file into the ide.
It does not build giving "cmd.exe exited with exit code 3". Exit code 3 means path not found. So a path problem.
Anyone can point me to where to look to fix? thx

By Manuel

Ascended (14327)

Manuel's picture

24-02-2018, 20:08

Doesn't it say what it is missing?

By PingPong

Prophet (3093)

PingPong's picture

24-02-2018, 23:40

Manuel wrote:

Doesn't it say what it is missing?

the problem is an incorrect path set to the spawned process cmd.exe.
unfortunately, it does not tell much about the path not found... (exit code 3)

By Manuel

Ascended (14327)

Manuel's picture

25-02-2018, 00:16

When exactly does it give this error? What is listed in the output window of VS?

By PingPong

Prophet (3093)

PingPong's picture

25-02-2018, 11:06

Manuel wrote:

When exactly does it give this error? What is listed in the output window of VS?

a) when i try to build the project
b) the output window is what i've looked before asking and it is unfortunately not of help:

1>------ Rebuild All started: Project: openmsx-debugger, Configuration: Debug Win32 ------
1>  Generating moc_BitMapViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_BreakpointDialog.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_CommClient.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_ConnectDialog.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_CPURegs.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_CPURegsViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_Dasm.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_DasmTables.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_DebuggableViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_DebuggerData.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_DebuggerForm.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_DebugSession.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_DisasmViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_DockableWidget.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_DockableWidgetArea.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_DockableWidgetLayout.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_DockManager.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_FlagsViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_GotoDialog.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_HexViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_InteractiveButton.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_InteractiveLabel.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_MainMemoryViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_OpenMSXConnection.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_PreferencesDialog.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_Settings.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_SlotViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_StackViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_SymbolManager.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_SymbolTable.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_VDPCommandRegViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_VDPDataStore.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_VDPRegViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating moc_VDPStatusRegViewer.cpp...
1>  The system cannot find the path specified.
1>  Generating config headers...
1>  'python' is not recognized as an internal or external command,
1>  operable program or batch file.
1>  Generating moc_VramBitMappedView.cpp...
1>  The system cannot find the path specified.
1>  Generating qrc_resources.cpp...
1>  Generating ui_BitMapViewer.h...
1>  The system cannot find the path specified.
1>  The system cannot find the path specified.
1>  Generating ui_BreakpointDialog.h...
1>  Generating ui_ConnectDialog.h...
1>  The system cannot find the path specified.
1>  The system cannot find the path specified.
1>  Generating ui_PreferencesDialog.h...
1>  The system cannot find the path specified.
1>  Generating ui_GotoDialog.h...
1>  The system cannot find the path specified.
1>  Generating ui_SymbolManager.h...
1>  The system cannot find the path specified.
1>  Generating ui_VDPCommandRegisters.h...
1>  The system cannot find the path specified.
1>  Generating ui_VDPRegistersExplained.h...
1>  The system cannot find the path specified.
1>  Generating ui_VDPStatusRegisters.h...
1>  The system cannot find the path specified.
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.CppCommon.targets(171,5): error MSB6006: "cmd.exe" exited with code 3.
========== Rebuild All: 0 succeeded, 1 failed, 0 skipped ==========

i've cloned the entire project in /op .
It does appear that someone has hard-coded paths so without the same path configuration there is no way to make it work.

By Manuel

Ascended (14327)

Manuel's picture

25-02-2018, 12:55

Quote:
1>  'python' is not recognized as an internal or external command,
1>  operable program or batch file.

Try to install Python!

Page 2/3
1 | | 3
My MSX profile