Help with MegaFlashRom SCC + SD not working

Page 4/6
1 | 2 | 3 | | 5 | 6

By LowRes

Resident (49)

LowRes's picture

24-02-2018, 15:15

Here's the video: https://youtu.be/4oZM8JC3ktg

please excuse my ghostbusters Pajama pants, and the camera work from my 12 year old I dragged out of bed to record this video lol

In the video you will see I have Parodius loaded into flash which is a rom game not a disk image
1. I attempt to reset and hold ESC on boot to change the rom but it still loads Parodius
2. 2nd attempt I reset and try to hold ESC on boot but end up in the Panasonic OS (which happens once in a while)
3. 3rd attempt to reset and hold ESC on boot and parodius loads again
4. I boot into recovery, and demonstrate F1 does nothing, but other options do work
5. I exit recovery by hitting esc which proves the esc key works and not a keyboard fault

sooooo.... there you have it. Maybe it's my panasonic, maybe it's the cart, maybe it's the combination of having to hold ESC and DEL to also avoid the OS, I don't know and don't really care to mess around with this any further.

By Guillian

Prophet (3178)

Guillian's picture

24-02-2018, 15:23

Thanks!

It seems you have a problem in your keyboard.
In the first boot, ESC does not seem to work (game boots)
In the second boot, ESC seems to work (game is skipped) but internal firmware boots (DEL is not working)
In recovery mode, you press F1 but it does not start the erase process. You should get a "Are you sure?" message. (F1 is not working)

So, if you feel like doing it, try to check your keyboard from basic. Dont insert any disk or cartridge, boot into BASIC and try pressing each key to check which work.
F1 should print "Color", DEL should work as "Supr", etc.

By LowRes

Resident (49)

LowRes's picture

24-02-2018, 15:37

Guillian wrote:

Thanks!

It seems you have a problem in your keyboard.
In the first boot, ESC does not seem to work (game boots)
In the second boot, ESC seems to work (game is skipped) but internal firmware boots (DEL is not working)
In recovery mode, you press F1 but it does not start the erase process. You should get a "Are you sure?" message. (F1 is not working)

So, if you feel like doing it, try to check your keyboard from basic. Dont insert any disk or cartridge, boot into BASIC and try pressing each key to check which work.
F1 should print "Color", DEL should work as "Supr", etc.

did a quick check and you’re right about the F1 key not working, but DEL and ESC seem to be fine

I didnt know my F1 key wasnt working since I’ve nevet had to use it before. Rest of the keyboard seems fine though

By Meits

Scribe (5214)

Meits's picture

24-02-2018, 15:39

Test the ESC key in basic:

1 a$=inkey$
2 if a$=chr$(27) then beep
3 run

run

keep it pressed and listen if there's a constant stream of beeps coming from the speaker.

By Guillian

Prophet (3178)

Guillian's picture

24-02-2018, 15:42

A similar program:

1 a$=input$(1)
2 print asc(a$)
3 goto 1

ESC should print 27
DEL = 127
Holding DEL+ESC 27 and 127

By LowRes

Resident (49)

LowRes's picture

24-02-2018, 16:02

You see escape works in the video since you have to hit ESC to exit from recovery, as for te delete key I use it all the time to bypass the panasonic OS and play games off floppy disc.
DEL + R even works with the megaflash rom to disable nextor

maybe the problem is intermitten though, these keyboard are old and might not be 100% every key press

By Guillian

Prophet (3178)

Guillian's picture

24-02-2018, 16:10

Yes, it seems some keys does not work, and other does intermittent.
Proabably you need to clean the keyboard membrane.

Please, confirm me if you still want to continue with the PayPal claim, now that we know the problem is related to the keyboard of your computer.

By LowRes

Resident (49)

LowRes's picture

24-02-2018, 16:30

Guillian wrote:

Yes, it seems some keys does not work, and other does intermittent.
Proabably you need to clean the keyboard membrane.

Please, confirm me if you still want to continue with the PayPal claim, now that we know the problem is related to the keyboard of your computer.

yes I want to return it. I'm not saying it's my keboard lol. I'm saying yes it's possible that it doesn't register 100% of the time but the ESC key and DEL key work fine for everything else except for when using with the cart

if anything, I’d blame it more on the panasonic OS and having to press both ESC and DEL at the same time, but I know others use the cart with panasonic and it’s ok. Anyway thanks for everybody’s suggestions but for me I just want to return it and stick to buying original carts

By Guillian

Prophet (3178)

Guillian's picture

24-02-2018, 17:38

You can configure the cartridge to skip the ROM pressing DEL, so holding only that key would skip the internal firmware and the flashed ROM (e.g.: OPFXSD PARODIUS.ROM /T83) It is also possible to configure MultiMente to apply that option when pressing RETURN on a ROM file.

Anyway, I'll reply to PayPal and inform them about we have find out. I hope you can understand that I don't agree your claim that the cartridge is faulty.

By Manuel

Ascended (14791)

Manuel's picture

24-02-2018, 21:41

Better check whether DEL and ESC work all the time or only half of the time or so.

In any case, you should be able to use the cartridge normally if you got the keyboard problems fixed, I think. Especially if you set the key to DEL as Guillian suggests, you should be completely GO on using this cart.

Page 4/6
1 | 2 | 3 | | 5 | 6
My MSX profile