MSX games on modern day PC

Page 1/2
| 2

By marcopolo650

Rookie (20)

marcopolo650's picture

23-03-2012, 00:40

MSX gurus,
IS there a way to play MSX games on a modern day PC? if yes, how is it done and where to get or download these games in that format from? thanks agin Smile

Login or register to post comments

By wilsone73

Expert (103)

wilsone73's picture

23-03-2012, 09:31

Hi

use the bluemsx emulator and google for roms, very easy to use!Smile

By marcopolo650

Rookie (20)

marcopolo650's picture

23-03-2012, 17:12

where can I get the bluemsx emulator from, is it a downloadable file of the web? Thanks for the info and help Wilsone73Smile

By hap

Paragon (2036)

hap's picture

23-03-2012, 17:48

surely you could have googled that Tongue
http://bluemsx.com/

Also, if you like reading and want to know more about emulation, Wikipedia is a good start:
http://en.wikipedia.org/wiki/Emulator (assuming you're totally new to emulation)

By anonymous

incognito ergo sum (116)

anonymous's picture

23-03-2012, 17:52

Or openMSX as well:

http://openmsx.sourceforge.net/

By anonymous

incognito ergo sum (116)

anonymous's picture

24-03-2012, 19:52

I did download the bluemsx emulator version 2.8.2 full, I also downloaded some rom games like Kings Valley 1&2, Vampire Killer 1&2 and some other ones, all were (j) version. my issue is that they play perfactly but the sound is horable, it sounds like the music is lagging so it is just one continouse anoying sound!!! what u think its causing this?!! the website I downloaded the games from called

{ moderated: links to copyrighted matherial are not allowed here - please re-read p.4.2 of Terms and Conditions page }

 Thanks allot guys:)

By marcopolo650

Rookie (20)

marcopolo650's picture

23-03-2012, 18:41

yes I am new to emulation hap, and thanx to all for the assitanceSmile

By marcopolo650

Rookie (20)

marcopolo650's picture

23-03-2012, 19:14

I actually downloaded the same games from another website and I still have an issue with the sound, is it my sound card that is causing this issue?!!  I'm using an old laptop with (Intel M730 1.6GHz, 2MB L2 Cashe, 533MB FSB, 2GB RAM, Intel GMA900-32MB Graphics processor and AC'97 Sounblaster pro)

By wilsone73

Expert (103)

wilsone73's picture

23-03-2012, 19:41

More likely the settings on the emulator, check that they are set correctly, sometimes you need to change them to suit the computer they are being played on.

i think you can adjust it to 16 bit sound quality and that should solve it.

By marcopolo650

Rookie (20)

marcopolo650's picture

23-03-2012, 20:07

I figuerd it out guys, I was supposed to eject the game before inserting the other one Tongue thanks anyways for all your info and help

By Manuel

Ascended (18082)

Manuel's picture

23-03-2012, 21:47

That fixes the sound!???!? Weird...

Page 1/2
| 2