7 Mhz issue and diskdrive issue

By Sky_hawk

Champion (267)

Sky_hawk's picture

22-10-2014, 20:09

I've got a 8235/00 with DOS2, 7Mhz and 1MB RAM and 64KB SRAM (custom) in it.
When I turn on the 7Mhz, the video (RGB) is distorded very slightly, but still annoying, it kind of looks like a very small vertical sinus distortion any ideas how to solve this?

I also has a DS-drive that is 5volt only, where the original SS-drive was 5+12v. if the head-position motor turns on, the screen is even more distorted, by kind of in the same way.

Any ideas are welcome.

Login or register to post comments

By Manuel

Ascended (15763)

Manuel's picture

22-10-2014, 22:13

Wasn't this due to a too big load on the 5V? I've heard about it before. I guess you need to fix up the PSU to support more stable (and more power on) 5V. Probably was described on the forum earlier.

By Zilogger

Resident (39)

Zilogger's picture

26-10-2014, 15:52

The distortion when using the FDD is a common thing when build a PC FDD (5 Volt only)
in a VG 8235/20 and a NMS8245 without using an extra 7805 to Power Supply the FDD only.

By Sky_hawk

Champion (267)

Sky_hawk's picture

01-11-2014, 22:33

I've tried a 7805, and it works ok, but it causes a lot of heat (obviously, because it has to dissipate (12-5)*1A = ~7 watts at full disk activity) and there is very little room for a cooling fin inside a 8235/45.

I solved this using a DC-DC converter,

http://www.ebay.com/itm/Mini-3A-DC-DC-Adjustable-Step-down-C...

It is an incredibly cheap and very effective device. It basically converts any input voltage between 4.5 and 28 volt to a adjustable output voltage. I have set it to 5 volt and it works like a charm! I used a scope to monitor the output voltage during heavy disk usage, it has a ripple of < 100mv which if fine for a diskdrive.

Anyway, no more nasty interference in the video anymore, I'm very happy with this result...