Bricked Neo Zemmix

Page 2/5
1 | | 3 | 4 | 5

By toticb

Master (213)

toticb's picture

04-08-2014, 22:57

Ok i will keep your advices.

Thanks.

By Retrofan

Paragon (1264)

Retrofan's picture

05-08-2014, 07:52

Thanks for your advice KdL! Wink

By gdx

Enlighted (5026)

gdx's picture

05-08-2014, 12:59

I bought a USB Blaster ALTERA on ebay for about $ 6 (free chipping). It works well.

By PipoBimbo

Supporter (12)

PipoBimbo's picture

06-09-2014, 17:09

Hi,

I've got the same problem.
I recently bought a zemmix neo and tried to flash it with the 3.2 firmware following the guide in this thread :
flashing firmware

I've never used anything else than a MSX 1 so maybe my limited knowledge of MSX-DOS is also to blame.
Here's what I did :
1. formatted a 2 Gb card with panasonic sd formatter in FAT format (on a Mac, I've already successfully used it for other devices who require FAT 16 cards but that may be part of the problem).
2. put MSX-DOS.SYS and COMMAND.COM 2.44 on the card (got them from a "msxdos244_20101130" archive).
3. booted the zemmix with the card : with the VGA out plugged into my monitor, it showed the disk prompt.
4. back to my mac, copied ocm-pld v3.2/firmware/zemmixneo_fr/msx2plus_znlogo/ems_top.pld along with pldflash.com in a KDL folder on the card.
5. booted the zemmix with the card, typed "pldflash emsx_top.pld" on the prompt. I got a message saying I shouldn't turn the zemmix off, then saw a countdown from 30 to 0. When the countdown ended, I was back at the prompt. I assumed the flashing process had finished, I typed "return" to be sure the computer was not busy and it displayed a new prompt line. I turned the zemmix off.

Now every time I power it on, the only thing I get is a white screen. The top led is blinking endlessly (I assume it's the disk activity).
I tried to boot it without the SD card or with a cartridge inserted and it doesn't change anything.
I tried to use the composite output (using the dip switches or the print screen key method) but the result is the same.

Now to the un-bricking part :P (on a windows computer this time) :
I bought an alter usb programmer from kdl's link. I downloaded the flashing software and used the recovery.pof (the first I used was from the 3.2.2 zip, when I originally flashed the 3.2 firmware, I don't know if it makes a difference).
At first I only checked the first column of boxes ("program" if I remember correctly) but then I checked all of them (program, erase, verify ...), the process took about a minute and ended successfully.

Sadly, nothing changed, I still get the same white screen when starting the zemmix.
I tried flashing several times with the 3.2 recovery that was next to the firmware I used, but with the same result.

Now I have exhausted every idea I've had, I'm hoping someone can help me in reviving my zemmix.

Side question : can I use the altera programmer to flash a firmware without using the msx-dos method ?

Thanks in advance.

By KdL

Paragon (1415)

KdL's picture

16-10-2014, 21:22

For all those Zemmix Neo (Lite) that do not work properly after a flash of the latest firmware, the workaround is to re-flash it using this old firmware temporarily: unbrick_zneo_32rc4_fullsize.zip

I'm sorry this version is working but it's very outdated.

By KdL

Paragon (1415)

KdL's picture

17-10-2014, 10:39

ps. it is known that only some Zemmix Neo (lite) machines has this hardware issue

By toticb

Master (213)

toticb's picture

17-10-2014, 18:49

Thanks kdl,this recovery file works fine.
Pipo bimbo, try with this file,i have the same problem that you explain and with this recovery the zemmix is another time working fine.
Thanks

By PipoBimbo

Supporter (12)

PipoBimbo's picture

20-10-2014, 10:01

In fact, this solution was tested by KdL directly on my zemmix Wink
Thanks again for your help !

By KdL

Paragon (1415)

KdL's picture

15-11-2014, 21:35

Hi PipoBimbo & toticb, could you test the Zemmix Neo with OCM-PLD v3.3 RC1?
Stability has improved when booting, thanks in advance.

http://www.webalice.it/gnogni/
http://gnogni.altervista.org/

By PipoBimbo

Supporter (12)

PipoBimbo's picture

17-11-2014, 19:15

Hi KdL,
This update didn't work for my zemmix. I used quarth to flash the recovery.pof directly. I only get a black screen.
Back to 3.2rc4 for me Wink

Page 2/5
1 | | 3 | 4 | 5