Can not get GR8NET in Symbos

Page 1/3
| 2 | 3

By JohnFante

Resident (62)

JohnFante's picture

25-10-2017, 21:10

I can not get my GR8NET online in Symbos. No problem getting online in basic mode etc. but even thou I follow the manual and it says it is online there is no connection.

Here is what I have done.

Copied commad2.com and nextor.sys to my SD card so that I can run Nextor when I write callnetsetmap(24,1) and boot symbos. Everything fine so far.

I then set up the network deamon with theese numbers that I get when I boot:

https://www.dropbox.com/s/2wjsu4ktqbmv6tl/IP.jpg

And setup the MAC:

https://www.dropbox.com/s/6z1quufrxww3eow/Driver.jpg?dl=0

IP adresses and DNS:

https://www.dropbox.com/s/5ahx9qi4efav6z0/TCPIP.jpg?dl=0

And as you can see here it goes online but there is no connections in netstat:

https://www.dropbox.com/s/8mxt65h5mtp8lsp/Status.jpg?dl=0

And SymIRC has no connections etc.

Any suggestions?

Login or register to post comments

By Meits

Scribe (5347)

Meits's picture

25-10-2017, 21:34

I just tested it briefly and had no issues. I start the network daemon for gr8net and it worked well after doing a few things.
- Start the network daemon (obvious Wink )
- In status tab press Network settins and obtain an ip address automatically (do not enter the settings gr8net got on boot)
- Do the same in the DNS & Hostname tab
- You should be done here, unless I forgot something.

By Meits

Scribe (5347)

Meits's picture

25-10-2017, 21:46






By Meits

Scribe (5347)

Meits's picture

25-10-2017, 21:49

The thing I would like to fix is that the network daemon boots hidden by default. Haven't found out how to do that yet.

By Prodatron

Paragon (1788)

Prodatron's picture

25-10-2017, 23:12

@Meits, thanks a lot for your help!
To run the Network Daemon in hidden mode during autostart, just check the option "Hide on startup" in the file menu.

@John: Probably you have an older Network Daemon version from the website. The actual one is inside the current 3.0 release package. Sorry for beeing lazy, I really have to run an update batch for several apps on the website now. I will try to finish this tomorrow evening.

By edoz

Prophet (2127)

edoz's picture

26-10-2017, 11:03

@Meits, besides check option "Hide on startup" you also need to put a link in the "auto start" folder of the startmenu.
(Than the application will start automatically during startup) .. Save it before restart (Start -> save settings.) (You can also enable auto save in the control panel. After that and after a proper shutdown it is saved as well)

Today i uploaded a movie about SymbOS (installation and configuration) which is very basic, but maybe it is helpfully as well) I'm planning to make more as well...

Installation and use

By Meits

Scribe (5347)

Meits's picture

26-10-2017, 11:26

That I already found out. Actually, it could be a nice feature to add it in the right mouse click contect menu of a file.

An other thing regarding Symbos and Gr8net is that only if I reboot the computer my Gr8net has some initialization problems. If I reboot from anywhere else all goes just fine. If Symbos is the cause, and I suspect it is since it's the only situation where it happens and it uses different network settings than Gr8net starts up with, I'd like to see that fixed Smile

By edoz

Prophet (2127)

edoz's picture

26-10-2017, 15:52

@JohnFante , i was looking to your screenshots and i'm sure you are using a old version of the daemon.

In the beginning the GR8NET was not having this mapper mode. The first daemon in SymbOS was not supporting this. version 0.2 (like in the screenshot from Meits) does support the GR8NET in mapper mode That is also the reason why DHCP is not working. As it looks you are using a fixed IP .. but i think (not sure) that you did a try on DHCP but was not working on that version as well in mapper mode.

So probably you need to replace it and will fix your problems.
If you are looking for the last IRC client it can be found on my website here. As prodatron needs to update his site :D :D

IRC

3.0 installation package

By JohnFante

Resident (62)

JohnFante's picture

26-10-2017, 20:49

Thank you for all the help :-)

I switched to the 0.2 version included in the distribution. That fixed the DHCP problem.

However I think I have a DNS problem of some sort since I still can not get online.

I will tinker a bit more with in the weekend and report back!

By JohnFante

Resident (62)

JohnFante's picture

27-10-2017, 18:02

Short update:

DHCP works and the deamon says that I am online. And the numbers match with the numbers I get when I boot.

But when I try to use SymMSG for example it says that it is resolving DNS and then just hangs there.

https://www.dropbox.com/s/w3lktdpg9eocmnn/DNS%20problem.jpg?...

I am a bit lost here. Have never had any DNS problems before. Things just normally work when I plug them in to my router, and there is plenty af connection when I callnetbrowse and broses Eugenys page.

Any suggestions?

By edoz

Prophet (2127)

edoz's picture

27-10-2017, 22:40

Some tips.

-Is the MAC address correctly displayed in SymbOS?
-Could you remove network.ini file from the disk and setup the daemon again.
-can you resolve a HOSTNAME in your local network ? (for example your PC?) you can use nslookup in the SymShell for this to test
- can you use google dns 8.8.8.8 (so let it on DHCP for the IP but for DNS set it fixed to 8.8.8.8)
- What is the firmware of the GR8NET?
- Do you use mapper mode 24,1?

Page 1/3
| 2 | 3
My MSX profile