Dead Yashica YC-64

Page 1/2
| 2

By Kacper

Rookie (30)

Kacper's picture

30-01-2021, 18:05

Hello! at the beginning, sorry for the spelling. I am writing via google translator.
I have a problem with the Yashica YC-64
I bought it from a local dealer. We write this in the advertisement "I have no way to check. I am selling as damaged"
MSX rarely appears in Poland. I bought 8 bit computers for my collection
the problem is this. after connecting the power, the power diode lights. after connecting to tv or via video or rf no picture. symptom like a computer dead
Where to start? you have to save MSX
unfortunately I don't have much knowledge of electronics
I greet everyone
Kacper Smile

Login or register to post comments

By sdsnatcher73

Paragon (1858)

sdsnatcher73's picture

30-01-2021, 18:19

Hi Kasper,

Easiest thing to check if there is no video (and this happens a lot: Can you hear keyclick from audio output if you press a key (then MSX is working only the video encoder is broken). Also CAPS light should toggle if you press the CAPS key. If both are not working then the problem is more serious. Possibly RAM/VRAM.

Cheers,
Peter

By Kacper

Rookie (30)

Kacper's picture

30-01-2021, 19:10

thank you
I will start by checking the audio and writing the result
greeting Kacper

By Briqunullus

Champion (343)

Briqunullus's picture

30-01-2021, 19:48

Ah, the beautiful red machine. I have had one in the past, but I sold it. Why isn't the machine listed in the Wiki?

By Jipe

Paragon (1484)

Jipe's picture

30-01-2021, 20:10

have you the good Din8 -> Peritel cable ?
info:if is a french model it's the same cable on the Canon V20
https://www.msx.org/wiki

By Manuel

Ascended (17877)

Manuel's picture

30-01-2021, 20:10

Hit "Next 200"....

By Kacper

Rookie (30)

Kacper's picture

30-01-2021, 20:40

my MSX that is sold in Germany and the Netherlands has an RF output and a composite output
good news - the keyboard does "pi, pi" I mean audio works Smile

By sdsnatcher73

Paragon (1858)

sdsnatcher73's picture

30-01-2021, 21:31

Okey, then most likely the LVA510 color encoder on the EMC-PX3067 daughterboard is dead but it may be the capacitors as well (although I have so far seen many MSX of which 2 had no video but did have sound and it was 2 times the LVA510).

By msxholder

Champion (379)

msxholder's picture

30-01-2021, 21:44

The same videoboard is used in the 8020 of Philips.

By Kacper

Rookie (30)

Kacper's picture

30-01-2021, 21:52

thank you sdsnatcher73. only now, please help with a photo of the element if the one we are looking for is different

By Briqunullus

Champion (343)

Briqunullus's picture

30-01-2021, 22:36

Briqunullus wrote:

Ah, the beautiful red machine. I have had one in the past, but I sold it. Why isn't the machine listed in the Wiki?

I can answer my own question. The category page for MSX1 Computers lists 200 machines per page. The Yashica is on the next page. My bad. I learnt something new today. B-)

Page 1/2
| 2