Denyonet

Page 4/7
1 | 2 | 3 | | 5 | 6 | 7

By Sd-Snatcher

Hero (582)

Sd-Snatcher's picture

09-04-2011, 20:55

You need to install http://www.winpcap.org/ before.

By edoz

Prophet (2400)

edoz's picture

09-04-2011, 22:21

Ok, I just installed it on my Windows Computer. I see now some option in the ethernet selection in BlueMSX. (i see 2 IP numbers) and one with 0.0.0.0
I boot the MSX with the network- disk. I configured the MSX IP, Subnet and Gateway and DNS servers manualy .. with the TCPIP util... I just take a IP number in the same range as my network... (DHCP is not working.. there is one running in my network.. so ..)

But if i ping something i'm not able to ping a host .. not by IP or DNS name.

Some options ?

By konamiman

Paragon (1157)

konamiman's picture

09-04-2011, 23:15

1) Make sure that in "Options - Ethernet interface" in blueMSX you have a valid interface selected. Not the one with 0.0.0.0, but one with a valid IP address for yout PC. Note that you can't change this setting while the emulation is running.

2) If you have a DHCP server in the network, the MSX should automatically get an IP address. (check it by executing "INL S" or "TCPIP S" ). If not, there is something wrong with the network emulation and configuring the IPs manually will not help.

By edoz

Prophet (2400)

edoz's picture

09-04-2011, 23:27

i was already testing.. and i selected indeed the IP from my Windows Machine in Blue MSX. For some reason .. i'm able to ping the Windows Machine from the MSX and also i can ping the MSX from a windows machine.. so it seems the network is working.. but i'm unable to see other devices in my network .. for example my router.. (is also the DNS server) .. Msx had the same subnet en GateWay .. but for some reason it cannot connect true the gateway (a ping to the gateway is also not working... )
But .. who this is realy cool stuff you created ... Wink

By edoz

Prophet (2400)

edoz's picture

09-04-2011, 23:32

Oh ... by the way ..... emulation Wink .. i hope the hardware is soon there... Big smile

By konamiman

Paragon (1157)

konamiman's picture

11-04-2011, 09:00

So, did you finally try the applications in blueMSX? Did everything work?

By enribar

Paragon (1144)

enribar's picture

11-04-2011, 16:04

Me too, still have problems with ObsoNET and blueMSX emulation.
So, please someone could provide a all-inclusive ZIP file with:

- the right ROM (ObsoNET or Denyonet? v.1.0 or 1.0?);
- a DSK with a BAT file for autoconfiguration of the environment;
- working software (TFTP or TELNET? etc.).

And all infos to configure blueMSX for a correct emulation (since Konamiman told me that with some blueMSX configurations, ObsoNET doesn't work properly/hangs).

Thankyou in advance.

By konamiman

Paragon (1157)

konamiman's picture

11-04-2011, 16:30

the right ROM (ObsoNET or Denyonet? v.1.0 or 1.0?)
You need the ObsoNET BIOS v1.1. You can download it here:

konamiman.com/msx/obsonet/bios.rom

a DSK with a BAT file for autoconfiguration of the environment
There is such a disk image available at my web site since a few days ago:

konamiman.com/msx/networking/msxinet.zip

You will seee "Type INET to install the TCP/IP stack" when you boot the emulated MSX with this disk. There is a INET.BAT file in the disk that installs InterNestor Lite.

working software (TFTP or TELNET? etc.).
That's on the disk image as well.

And all infos to configure blueMSX for a correct emulation (since Konamiman told me that with some blueMSX configurations, ObsoNET doesn't work properly/hangs).
I don't remember about the hanging stuff :) Anyway all you need is to ensure that winpcap is installed, you have an ObsoNET inserted in one of the slots of the emulated MSX (with BIOS 1.1), and you select an appropriate network interface on blueMSX ("Options - Ethernet interface" in blueMSX).

By the way, all of my networking applications (except perhaps the older ones) need DOS 2 to work. I recommend you to emulate a Turbo-R, which has the DOS 2 kernel built-in.

By enribar

Paragon (1144)

enribar's picture

11-04-2011, 17:09

Thankyou Konamiman, so:

0) install blueMSX and Winpcap;
1) You need the ObsoNET BIOS v1.1 konamiman.com/msx/obsonet/bios.rom
2) inserted ROM in one of the slots of the emulator and select Options - Ethernet interface
2) use this ready-made DSK: konamiman.com/msx/networking/msxinet.zip
3) type INET to install the TCP/IP stack" when you boot the emulated MSX with this disk (there is a INET.BAT file in the disk that installs InterNestor Lite)
5) all of my networking applications (except perhaps the older ones) need MSX-DOS 2 to work. I recommend you to emulate a Turbo-R, which has the DOS 2 kernel built-in.

Thankyou

By enribar

Paragon (1144)

enribar's picture

11-04-2011, 17:59

Test results following previous instructions:

Emulator: blueMSX
Machine: MSXTurboR

InterNestor Lite is installed and ACTIVE

Network state is: ON

Local IP address: 0.0.0.0
Subnet mask: 0.0.0.0
Default gateway: 0.0.0.0
Primary DNS address: 0.0.0.0
Secondary DNS address: 0.0.0.0

DHCP automaton state: SELECTING

... but nothing works ...
Is it possible to see a Youtube video with a step-by-step configuring procedure?

Page 4/7
1 | 2 | 3 | | 5 | 6 | 7