FM-Pac and Panasonic FS-A1FX

Page 1/3
| 2 | 3

By rolins

Champion (418)

rolins's picture

21-12-2008, 20:47

Is there a reason why I can't hear msx-music when I have the FM-Pac inserted in my Panasonic FS-A1FX? I've tried the basic command CALL FMPAC and attempted to listen to the BGM tracks, but I get nothing but silence. When I play Aleste + FM-Pac I can't hear msx-music, not even PSG. But if I turn on the system without the FM-Pac, I can hear PSG. This really strange.

Login or register to post comments

By JohnHassink

Ambassador (5451)

JohnHassink's picture

21-12-2008, 21:10

BASIC command = "CALL MUSIC".
But such command should be in the music files itself already.

I don't know about this specific MSX machine and why it could have problems with the FM-Pac, sorry.
So you get no sound effects with Aleste then?
Have you tried other ROM's as well?

By Manuel

Ascended (16626)

Manuel's picture

21-12-2008, 21:59

Maybe the volume of the MSX-MUSIC is very low? Try to adjust the switch in the FM-PAC.

By rolins

Champion (418)

rolins's picture

21-12-2008, 22:09

BASIC command = "CALL MUSIC".
But such command should be in the music files itself already.

I don't know about this specific MSX machine and why it could have problems with the FM-Pac, sorry.
So you get no sound effects with Aleste then?
Have you tried other ROM's as well?

No sound effects, although I can still get system bleeps. I've tried other roms like Xevious and disk games like Last Armageddon. Still no music.

Maybe the volume of the MSX-MUSIC is very low? Try to adjust the switch in the FM-PAC.

Tried, nothing happened. Sad

By Vincent van Dam

Hero (513)

Vincent van Dam's picture

21-12-2008, 23:30

Did you clean the cartridge pins? Maybe the pins (or slot) is just dirty and the fmpac rom therefor isn't found. If "call music" doesn't work either, I think that's very likely the problem.

By Manuel

Ascended (16626)

Manuel's picture

21-12-2008, 23:53

Or the sound pin of the FM-PAC cart is dirty.

It seems the FM-PAC is found, because there's no sound at all in Aleste. Besides, CALL FMPAC worked Smile

By rolins

Champion (418)

rolins's picture

22-12-2008, 01:32

Did you clean the cartridge pins? Maybe the pins (or slot) is just dirty and the fmpac rom therefor isn't found. If "call music" doesn't work either, I think that's very likely the problem.

Or the sound pin of the FM-PAC cart is dirty.

It seems the FM-PAC is found, because there's no sound at all in Aleste. Besides, CALL FMPAC worked Smile

Cleaning the edge connector on the FM-Pac changed nothing. There gotta be something wrong with it.

I was wondering maybe if the slot connector on the MSX2+ was at fault. I inserted my Snatcher sound cartridge and I can get full SCC+ music so I don't think the MSX2+ is at fault.

I have a Sony HB-F1XV MSX2+ I could try it on, but that computer has MSX-Music built-in. How would I disable the on-board YM2413 or force it to use the FM-Pac?

By Manuel

Ascended (16626)

Manuel's picture

22-12-2008, 09:46

Don't you have any other kind of MSX to try it in?

It seems that something is wrong with this FM-PAC... Sad

By Erikie

Champion (324)

Erikie's picture

22-12-2008, 10:41

you can only hear sounds on an FM-pac if the 12V works correctly. Without it you will get no sounds.
Check your 12V supply in your machine. Maybe that is your problem.
If your 12V supply is working properly then your FM-pac could be broken

By rolins

Champion (418)

rolins's picture

22-12-2008, 11:52

you can only hear sounds on an FM-pac if the 12V works correctly. Without it you will get no sounds.
Check your 12V supply in your machine. Maybe that is your problem.
If your 12V supply is working properly then your FM-pac could be broken

How can I check this without electrocuting myself?

By Erikie

Champion (324)

Erikie's picture

22-12-2008, 12:15

pin 48 is +12 V and pin 50 is -12 V
gnd = 41 and 43 (see here http://www.faq.msxnet.org/connector.html)
If you have a multimeter you can measure it straight from the edge connector.

Page 1/3
| 2 | 3