Getting a Sony HBP-F1C to go online

By sdsnatcher73

Prophet (2246)

sdsnatcher73's picture

06-07-2021, 11:34

So a while back I got a Sony HBP-F1C MSX printer. Today I decided to give it a try but when I turn it on the online light keeps flashing and it does not respond to pressing of the online button. Paper and ribbon cartridge are installed but it seems to think there is a problem. The ribbon cartridge carriage moves left initially but then moves to the middle. What I get from the Japanese manual that is the ribbon changing position (indicating it did not detect the ribbon?).

Does anyone have the same printer and has some tips here? Maybe some sensor needs cleaning?

Login or register to post comments

By Alexey

Guardian (3204)

Alexey's picture

06-07-2021, 15:38

My FS4600 also moves the head to the middle position by default to be in the middle of the paper when printing should start. Maybe you have black and white setting for the color cartridge or vice versa?

By sdsnatcher73

Prophet (2246)

sdsnatcher73's picture

06-07-2021, 15:10

The color / monochrome setting is correct (I tried with both cartridges in both positions, so 4 combinations), cannot get it to go into online mode so it will accept data from the MSX.

By Alexey

Guardian (3204)

Alexey's picture

06-07-2021, 15:38

Batch 5? Wink

By sdsnatcher73

Prophet (2246)

sdsnatcher73's picture

06-07-2021, 16:22

Sure

By RamonMSX

Expert (125)

RamonMSX's picture

07-07-2021, 07:26

I don’t think the cartridges are the problem. It is a thermal printer that also works without a cartridge installed using thermal paper. Of course only in monochrome setting.

By sdsnatcher73

Prophet (2246)

sdsnatcher73's picture

07-07-2021, 09:25

So possibly a paper sensor malfunctioning??

By Alexey

Guardian (3204)

Alexey's picture

07-07-2021, 15:52

Is the printer connected to MSX? Maybe it needs a connection to go online.

By sdsnatcher73

Prophet (2246)

sdsnatcher73's picture

07-07-2021, 18:02

Yeah I connected it to MSX. It also should go online without connection to allow for the test print to work (at least that is what I got from the manual)