Help hacking and restoring AX-350II sakhr

Page 3/17
1 | 2 | | 4 | 5 | 6 | 7 | 8

By ali6x944

Expert (127)

ali6x944's picture

22-01-2018, 19:24

Grauw wrote:

Yeah, there’s (at least) two versions of the CX5MII board, the CX7 one and the XB300 one. E.g. the description of the CX5MII conversion to MSX2 unfortunately references the XB300 board.

But if it’s the same board as the 805 (slightly odd, since the form factor is quite different), maybe this service manual will be of use: http://msx.hansotten.com/uploads/files/ax500servicemanual.pdf

The YIS-503IIR service manual is scanned as well, though I can’t find a download link...

About the board version mine is an XB633, reading the manual of CX5MII memory mapper for both video and main memory dose not seem to be upgrade-able by a simple jumper.
But I will check my computer's pcb for any signs of connectors or jumpers

By ali6x944

Expert (127)

ali6x944's picture

23-01-2018, 05:24

By Grauw

Enlighted (7317)

Grauw's picture

23-01-2018, 09:24

And a nice looking MSX-ENGINE Big smile.

By ali6x944

Expert (127)

ali6x944's picture

23-01-2018, 19:45

Thanks Grauw

By ali6x944

Expert (127)

ali6x944's picture

24-01-2018, 08:10

I was thinking about repainting the unit and msx labels, because they are faded in a couple of spots.
But I'm worried the spray paint wouldn't stick, and the tone might not be right, so if any one has a good photo of their unit's label
That would be highly appreciated. Wink

By ali6x944

Expert (127)

ali6x944's picture

25-01-2018, 08:20

Quick update on the ram expansion...
In the wiki page it says

Quote:

This model have the RAM on the motherboard. It can be expanded to 256KB by adding four same RAM and a jumper "-J-". The RAM expansion of 1024kB from Alexey is not supported.

This improves chances for a quick expansion, although they didn't specify it's location on the board...
Also I have to note what looks like a unpopulated connector near the B carriage slot, maybe that is used for some memory upgrade of some sort.

By ali6x944

Expert (127)

ali6x944's picture

26-01-2018, 05:43

https://drive.google.com/file/d/11nkUPKFp-ZqNw-BXpNEROc97Pca...
Found "-J-"!
Also my unit is acting weird the video out is deformed and certain keys are stuck on, I don't know what is going on but I think it is because I washed it with isopropyl alcohol last night to remove the flux residue of the board and to clean it a bit from dust and stuff like that.

By Alexey

Paragon (1579)

Alexey's picture

26-01-2018, 11:25

Alcohol should not be a problem unless you bathed the keyboard in it. Alcohol evaporates quickly leaving no conductive residue. Make sure the keyboard and other connectors are correctly connected.

By ali6x944

Expert (127)

ali6x944's picture

26-01-2018, 14:38

After a bit of tinkering I found out the reason, it is the alcohol mix, the water in it didn't evaporate and some shorted the metal shield with some of the pins of the V9938 causing the weird effects I previously described.

By ali6x944

Expert (127)

ali6x944's picture

26-01-2018, 14:40

I took it to dry after I washed it with some oxi clean detergent and now its fine.

Page 3/17
1 | 2 | | 4 | 5 | 6 | 7 | 8
My MSX profile