MSX Monitor question

By Samor

Prophet (2121)

Samor's picture

29-07-2005, 09:11

My MSX monitor has started to produce a lot of noise lately, a static sound, it's becoming more and more now. I've had it before but then it suddenly stopped doing that and worked normally for 3 more years.
Does anyone here know what I'm talking about and can tell me what this is ?

Login or register to post comments

By ro

Scribe (4562)

ro's picture

29-07-2005, 10:41

sound like you need to re-solder some prints, had that same prob on almost every monitor I ever owned.

By flyguille

Prophet (3028)

flyguille's picture

29-07-2005, 12:18

static noice???

it is like... a HIGH VOLTAGE escape? that sounds like a blow of electricity. If that is true in days with a lot of humidity it sounds worst!

By Meits

Scribe (6474)

Meits's picture

29-07-2005, 14:05

Had it as well... I still own the same monitor and it's not being repared... It happened to be dust in the high voltage part... Blew it away...

By SKiLLa

Expert (97)

SKiLLa's picture

30-07-2005, 16:14

Yes, you might try & clean it - vacuumcleaner perhaps ?
I've had it too sometimes, and even a good hit to the side of monitor could help.
If it only gets worse you'd better let an expert (like Repair-Bas) look at it ...

By Samor

Prophet (2121)

Samor's picture

30-07-2005, 20:09

thanks. I will try.
By the way, the speaker sound recently also became distorted, but it's not all the time. I don't know if it's related (either way I use a stereo set for sound rather than the monitor output anyway)...