NOS Canon V20 black screen

Page 4/4
1 | 2 | 3 |

By tilatax

Rookie (23)

tilatax's picture

09-09-2018, 17:22

Yest this makes sense. Thank you. I will swap the VDP first, if it does not help I will replace the CPU. I wait for the solder sucker to ensure nice clean work. I really appreciate your help guys. This resuscitation turned into major operation, but gave me good opportunity to read and learn about the Z80. Despite being unsuccessful I am actually really enjoying it.

By tilatax

Rookie (23)

tilatax's picture

15-09-2018, 21:41

I have replaced VDP, Z80 and VRAM (all socketed now) . Same problem.
I am about to giving up. Crying
Any ideas?
The solder sucker is amazing though.

By Alexey

Guardian (2792)

Alexey's picture

15-09-2018, 22:45

Did you test all those chips in a working computer? If not, please make sure you test them before giving up. As the last resort you can send the computer to RepairBas. He will fix it for you for a reasonable price.

By tilatax

Rookie (23)

tilatax's picture

18-09-2018, 18:19

Yes, all good. I was wondering if the ROM might be the issue, not being able to load and so getting into a boot loop. All the components are considerably hotter than the Yashica YC64's. Does the MSX1 ROM tend to fail with time. It is a proper ROM not eprom, right? The other, and last, option is that the RAM is bad, so the ROM can't be copied into RAM and gets into boot loop?
What do you think?

By RetroTechie

Paragon (1563)

RetroTechie's picture

19-09-2018, 00:05

This would be the time to plug in a RAM cartridge - as suggested in my very first post in this thread. If you don't have one, go buy / borrow / steal one. LOL! It's an essential help for fault finding in dead MSXes. And dead / bad RAM chips inside the machine don't (usually!) interfere with a RAM cart that's plugged in.

Bad RAM is MUCH more common than bad ROM chips. Not the least because main RAM is usually divided over several IC's (like 2 or 8 pcs), where only 1 has to go bad for the RAM to not work.

By calderone

Supporter (10)

calderone's picture

06-07-2020, 22:56

Any outcome or update on this problem ? Please post your solution if you have one !
Often when a solution is found, the thread is often not updated with its solution?
...not accusing anyone ;-)

Nevertheless, I have a very similar problem with a VG-8010, see also these threads:
https://www.msx.org/forum/msx-talk/hardware/vg8000-and-vg801...
https://www.msx.org/forum/msx-talk/graphics-and-music/functi...

I'm still strugling and I have tried and tested already a lot, but the screen stays pitch black :-(
In short summary:
- Swapped VDP, CPU, VRAM, DRAM
- swapped and tested many logic chips
- reset signal is working
- tried other Eproms (to replace the orig. ROM)

In these comments, I see a lot of similarity... especially the VDP with a HIGH /INT pin.
So the VDP is not generating an /INT signal of 50Hz
But when testing the VDP (See https://www.msx.org/forum/msx-talk/graphics-and-music/functi...), I'm able to put the /INT pin LOW by reading the status register.
So I believe the VDP is functional, meaning the 'stuck' /INT signal should have another cause ??

I'm also thinking to create a MSX1 test cartridge (see, https://hansotten.file-hunter.com/special-msx-hardware/phili...)
But if video does not seem to work, it seems a bit useless, no ??

@RetroTechie: You suggest a RAM cartridge: Would this help here and what cartridge would you suggest to test this VG-8010 (MSX1), or is it also useless without video ?

Page 4/4
1 | 2 | 3 |