Nowind, Mac and Linux

Page 6/7
1 | 2 | 3 | 4 | 5 | | 7

By Haohmaru

Paladin (773)

Haohmaru's picture

24-07-2012, 19:09

Ok.

'nwhostapp -twrite' (Nowind in slot 1):
makes 'Hello MSX!' appear on the MSX side, so that's good. Obviously I had no issues flashing and sending disk images to the other cartridge using the same machine, OS, USB port and cable.

Funny thing that it just does not want to write to flash to this particular cartridge in slot 1...

Nowind in slot 2:
O_o ... Success!
It flashed, I can send disk images, etc!

Now it also works in slot 1 again...

Odd. (no not the Norwegain democrew who made this :D)

Anyway, at least I got everything working (again) - THANKS!

:RNFF:

FYI: I used a 8245 (no modifications) to flash and test both Nowind cartridges.

By Sky_hawk

Champion (267)

Sky_hawk's picture

24-07-2012, 21:20

So, you got it working, great! And all information on the site, and the information in this thread was absolutely correct, even better!

Now all the remains is finding out why it doesn't compile out of the box on Ubuntu 12, the good news is: I have installed Ubuntu 12 in a VM and can confirm the issue, the bad news is, I have no clue why it is happening yet.

Could you please report the issue using:
http://code.google.com/p/nowindlibraries/issues/list

that will help us keep track of the issue.

To anyone with cmake knowlegde: I would really appriciate help on this issue, I cannot
seem to get cmake to link any external libraries on Ubuntu 12 (i'll need to cross-test but I doubt it is ubuntu 12 specific)

Greetings,

Jan

By Haohmaru

Paladin (773)

Haohmaru's picture

24-07-2012, 21:37

Issue reported.

Note that using just make and the Makefile Edwin posted a few pages ago will result in a working nwhostapp.

By Sky_hawk

Champion (267)

Sky_hawk's picture

24-07-2012, 21:39

Ok, I just re-tested:
- on Fedora 13, cmake 2.8.0, no issues
- on Ubuntu 12, cmake 2.8.7 however, no go.

I will now test on Debian 3.2-64, just because that what manuel uses Smile and because I have a VM of that.

Will keep posting results as I get them.

-Jan

By Sky_hawk

Champion (267)

Sky_hawk's picture

24-07-2012, 21:40

Haohmaru,

Thanks for reporting the issue! including the workaround.

Gr,

Jan

By Manuel

Ascended (18133)

Manuel's picture

24-07-2012, 22:07

I'm using cmake 2.8.9, and I also had to manually tweak stuff to get it working, remember?

I still get this:

$ make
Linking CXX static library libnwhost.a
Linking CXX static library libnowind.a
Linking CXX static library libftdx.a
Linking CXX static library libnwgeneral.a
[  9%] Built target nowind
[ 18%] Built target nwgeneral
[ 51%] Built target ftdx
[ 87%] Built target nwhost
make[2]: *** No rule to make target `/usr/lib/libftdi.so', needed by `nwhostapp/nwhostapp'.  Stop.
make[1]: *** [nwhostapp/CMakeFiles/nwhostapp.dir/all] Error 2
make: *** [all] Error 2

By Sky_hawk

Champion (267)

Sky_hawk's picture

24-07-2012, 22:20

I seem to have fixed the problem for ubuntu 12, appearently, newlines (and non-ascii chars) do not agree with cmake in some places. I have moved some stuff onto single lines and that seems to have fixed it. Haohmaru, could you retest building nwhostapp using cmake ?

manual, you too ?

Greetings,

Jan

By Haohmaru

Paladin (773)

Haohmaru's picture

25-07-2012, 19:02

With the current nowindlibraries source from svn, this:

export BOOST_ROOT=/usr/include/
cmake -G 'Unix Makefiles'
make

results in nwhostapp being built. Unable to test with the Nowind cartridge at the moment though, due to not having my MSX setup outside Wink

By Manuel

Ascended (18133)

Manuel's picture

25-07-2012, 21:18

Nope I still get the same error.

By Sky_hawk

Champion (267)

Sky_hawk's picture

25-07-2012, 21:30

manual, weird, please post the full output from 'touch CMakeList.txt + make '
and the link to the ISO of the distribution you're using, I installed debian 64 and got not such problem.

Gr,

Jan

Page 6/7
1 | 2 | 3 | 4 | 5 | | 7