Philips VG-8235/22: video display starts flickering after 10 minutes...

By defdanny

Master (254)

defdanny's picture

06-04-2021, 16:27

Hi all,
like myself, my good ole VG8235 is not getting any younger.
Recently I have observed that the video image starts to flicker after 10-15 min in operation.
Switching the computer off and on does not really help, but I have the impression, that after a short pause the video signal is stable again... until after 10 min later it starts to become instable again.

I have very little hardware knowledge. Can someone give me a clue, what video output component could be the source of this failure? How can it be fixed?

Login or register to post comments

By Rataplan

Master (244)

Rataplan's picture

06-04-2021, 18:48

Sounds to me like capacitors getting at the end of their life. Without soldering experience it's probably better to have someone else take care of that. But if it is the capacitors, it's an easy fix.

By defdanny

Master (254)

defdanny's picture

06-04-2021, 19:30

Hi, thanks Rataplan. I often read about the capacitors being the main reason for old hardware to fail.
Well, I have a bit of soldering experience and the equipment. Can you give me a hint, where (maybe here on MRC) I should search for further information?

By Repair-Bas

Paragon (1108)

Repair-Bas's picture

06-04-2021, 21:03

It look like the voltage regulator

By defdanny

Master (254)

defdanny's picture

06-04-2021, 21:11

Hi Bas,
may I PM you?

By Repair-Bas

Paragon (1108)

Repair-Bas's picture

23-04-2021, 09:58

Problem solved.
New video-board and 7912 (voltage regulater)

By defdanny

Master (254)

defdanny's picture

05-05-2021, 14:00

I really would like to thank Bas for his help! He directly contacted me and we analyzed the issue directly in a video conference call. Fantastic! Thanks again, Bas. I learned a lot in this "I can fix it" session!
Maybe you should think of producing and publishing some Repair videos, like on https://www.ifixit.com/Guide