Problems with the NMS8245 and BIOS Basic 3.0

Page 1/4
| 2 | 3 | 4

By Pablibiris

Paragon (1812)

Pablibiris's picture

25-03-2015, 10:51

Hi all!
I have a strange problem with one NMS8245. I extended to MSX2+ this computer and now only works with the original BIOS.
When I put a Basic 3.0 Bios,I have a black screen,the CAPS key lights on,and the tape relay is actived (the same symptoms as if he were not placed the BIOS eprom) I used different eproms to make this.
I've never had this problem until now...A few days ago,I expanded a HB101 and I changed the BIOS without any problem,so I came to the conclusion that my eprom burner works correctly (I compared the .rom bios with the eprom information and all is ok)
Someone had this problem before?
Thanks!

Login or register to post comments

By Jipe

Paragon (1561)

Jipe's picture

25-03-2015, 14:17

check if your rom is with or without F4 port

By usuario_msx2

Paladin (756)

usuario_msx2's picture

26-03-2015, 13:11

Is possible your bios file(you used for burning your eeprom with basic 3.0) is not correct.
I have one with basic 3.0 and works fine with nms8245.

By Pablibiris

Paragon (1812)

Pablibiris's picture

31-03-2015, 20:21

I think that the eprom that I used was the problem. I'm waiting for more EPROMS Smile
Thanks again!

By Manuel

Ascended (18958)

Manuel's picture

31-03-2015, 20:33

You could experiment in an emulator to find out whether the ROM is OK or not.

(So, make sure you use the 8245 config and add the proper reset status register, or leave it out if you didn't put that hardware in the modified 8245.)

By Pablibiris

Paragon (1812)

Pablibiris's picture

18-04-2015, 00:28

Well...Today has arrived the Eproms needed. But the problem persist...
Is strange!,with the original Bios it's all OK...but with a Eprom,the computer is in black screen,the caps key locked,and the cassette relay is ON (like no one Bios is installed) I use the same ROM,that I always use to make this expansion and I never had a problem...

By Jipe

Paragon (1561)

Jipe's picture

18-04-2015, 14:53

the original rom have 64k and the 2+ required a 16k added
i make it on a 8235 / 39 in past
http://www.msxvillage.fr/forum/topic.php?id=475&pt=3
files for the roms is on upper post

By Pablibiris

Paragon (1812)

Pablibiris's picture

18-04-2015, 15:24

mmm..thanks Jipe,but I think that is not the same method. The Roms are not the same for 8235 and 8245,because I only have a socket to put a EPROM Sad

By Jipe

Paragon (1561)

Jipe's picture

18-04-2015, 15:38

just the 8235/00 and /19 have 3 socket for eproms
-
the 8235/39 have only a socket for a 64K eprom , the 16k is solder upper the 64k
the rom file have the FDD of 8245 because the 8235 have change floppy for 2 sides
-
8235/39 and 8245 are very similar inside Wink

By Pablibiris

Paragon (1812)

Pablibiris's picture

18-04-2015, 15:42

Ahá! Nice!
Jipe,please,can you translate this text? (I dont understand all the text):

Quote:

pour le cablage il faut relever les pattes 1 , 20 , 22 et 27 de l'eprom 16k

souder les autres pattes sur l'eprrom 64k

cabler 1 et 27 sur le +5v ex patte 28 de l'eprom 64k

souder un fil entre la patte 20 de l'eprom 16k et le trou sous le premier 5 de 55

souder un fil entre la patte 22 de l'eprom 16k et le trou de TP2 dans le cercle blanc

c'est fini

By Jipe

Paragon (1561)

Jipe's picture

18-04-2015, 16:11

on the 16k eprom put the pin 1 , 20 , 22 and 27 horizontal
sold other pins on 64k eprom
sold the 16k pin 1 and pin 27 on the 5v ( pin 28 of 64k )
sold the 16k pin 20 on /CS1 pin 54 of gate array M60003A
sold the 16k pin 22 on /SLT 3/30 pin 48 of gate array M60003A
-
sorry for my very bad english , i added some details for adapt to 8245

Page 1/4
| 2 | 3 | 4