Replacing ROM in an MSX HX-10 with an EPROM

By M2X_E1

Rookie (19)

M2X_E1's picture

02-12-2018, 23:15

Hi guys,
I'm having some issues using a 27512 eprom with 32k msx rom stored on it (have duplicated at lower and higher 32kbytes so tjat it doesnt matter what A15 is set to).
The msx just doesnt do anything and ive checked rom over again on the programmer.

Any thoughts on this and the use of uv erasable eproms in place of original rom chip, do they normally work?

Thanks,
Ed

Login or register to post comments

By Alexey

Guardian (1752)

Alexey's picture

02-12-2018, 23:36

Yes, the UV erasable EPROMs as well as EEPROM chips should work fine in any older computer as long as their masked ROMs have standard pinouts. If a masked ROM has a different pinout, you need to make an adapter board. I ran into this problem with my CBM 4008 machine...

Try swapping the 16kb parts in each 32kb image, then burn both into the EPROM.

By M2X_E1

Rookie (19)

M2X_E1's picture

04-12-2018, 22:21

Thanks Alexey,
I've figured out that the socket for the rom doesnt habe much grip.
The chip kind of just sits in it so in addition to giving the pins a light abrasive filing, i lightly bent pins outward a tiny bit.
Seems to work ok now.
I tell you u wouldnt believe the issues im having to program a rom chip.
Not least the fact that a parallel port is not necessarily a real parallel port. Plus drivers are harder
To come by nowadays ive found.

Anyways much appreciate you confirming the chips are ok.

Regards
Ed

My MSX profile