Scramble characters when scrolling

Page 2/2
1 |

By blackmsx

Expert (77)

blackmsx's picture

25-12-2015, 16:31

Well, I guess the video chip (v9938) is gone. Sad

I get the MSX boot logo, I see nextor detecting devices message then the screen goes black...

I still hear the clicking when I press the keyboard...

By flyguille

Prophet (3028)

flyguille's picture

26-12-2015, 21:24

weird, weird weird, but 4.8 is a low measure, the +5v normaly is measured as 5v up to 5.2v, not 4.8v... check the psu caps.

By RetroTechie

Paragon (1563)

RetroTechie's picture

26-12-2015, 23:09

blackmsx wrote:

I've measured the tension inside the machine. I get +4.8 volts on the +5 rail and 11.7 on the +12 rail. The values dont change much when the IDE cart is plugged (they fall about 0.05 volts or so).

Ouch - that's way too much fluctuation! Shocked!

That model MSX has a so-called "linear" voltage regulator in it, rated for 2A continuous. In normal operation, expect 4.90~5.10V output. And when you add a small load like a cartridge, that would drop maybe 0.01~0.02V - at most.

Read: probably capacitors in power supply are failing. This causes the +5V to fluctuate more, and if you read 4.8V average, chances are dips go lower like down to 4.7V or worse. Possibly out-of-spec for some parts in the machine. And even if average were okay, such fluctuations could be enough to cause all kinds of erratic behavior. Not healthy for IC's either...

So listen to flyguille, and order some replacement caps for the one in your psu! Those in +12V and -12V circuits too. The larger value electrolytic capacitors, that is - primarily the ones in that hole in the cooling plate. And if you can find it & cheap enough, consider replacing that +5V regulator as well. Yes, even those robust regulators fail sometimes when they get old... LOL!

By blackmsx

Expert (77)

blackmsx's picture

27-12-2015, 00:13

Thanks for the advice. I'll recap the power supply circuit and see if it gets better.

Page 2/2
1 |