Sony HB-F1 no keyboard input at all

Page 1/4
| 2 | 3 | 4

By Dr.Wily

Rookie (22)

Dr.Wily's picture

18-02-2018, 16:41

Hello !
I have a Sony HB-F1 who seem to be in good working order. But it's only in appearance.

Unfortunately there is no keyboard input. I checked the membrane and it's OK. Shorted some pins of the keyboard connector (pins 2 + 7 = enter key) but it gives no result.

Last test, I keep the Y and P keys pressed at power up to display the credit screen. The screen appear but whit no scroll. I only have a grayish screen instead of Sony GUI. Strange...

What's happen ?
Thanks for your help Wink

Login or register to post comments

By gdx

Prophet (2358)

gdx's picture

20-02-2018, 01:40

Have you checked the voltages of the power supply? Chemical capacitors?
Do you have a memory expansion to check if it is not the RAM that is defective?

By Dr.Wily

Rookie (22)

Dr.Wily's picture

20-02-2018, 15:41

Voltages are the followings :

- 14v on 9v line
- no stable voltage on 18v line

All caps are in good condition.

By gdx

Prophet (2358)

gdx's picture

20-02-2018, 14:47

"Dr.Wily" wrote:

- 14v on 9v line
- no stable voltage on 18v line <--- there is the issue ?

No problem here. Check +5V and +/-12V inside.
Turn on the MSX without the batteries under unit. Try to see if it works with a memory expansion. Borrow from a guy if you do not have one.
Defective capacitors are not always visible to the naked eye.

By Dr.Wily

Rookie (22)

Dr.Wily's picture

20-02-2018, 15:55

+5v is OK
-12v is ok
+12v is ok

Unfortunately I don't have a memory cart. Others ways to check the RAM ?

By NYYRIKKI

Enlighted (5045)

NYYRIKKI's picture

20-02-2018, 16:06

If Y&P combo does something then the keyboard it self is not completely dead... Maybe ROM bit rot? Does the computer work ok with game cartridges & joystick?

By Dr.Wily

Rookie (22)

Dr.Wily's picture

20-02-2018, 16:38

joystick gives no result at GUI screen. The cursor don't move.
With Y&B combo I have this screen.
I have a P-BASIC cartridge, when it's inserted the BASIC menu show up with 1 for P-BASIC and 2 for normal BASIC, but I can't select because of a non responding keyboard.

By NYYRIKKI

Enlighted (5045)

NYYRIKKI's picture

20-02-2018, 17:25

I have a strong feeling that there is nothing wrong with your keyboard... The lack of response is now symptom caused by something else. Failed RAM would indeed be a good candidate.

By NYYRIKKI

Enlighted (5045)

NYYRIKKI's picture

20-02-2018, 18:57

Hmm... just an idea... After you boot up your computer normally, it probably says on 3rd line something like "xxxxx Bytes free" what is the "xxxxx"-number?

By Dr.Wily

Rookie (22)

Dr.Wily's picture

21-02-2018, 00:11

I believe that is the RAM too.

NYYRIKKI wrote:

Hmm... just an idea... After you boot up your computer normally, it probably says on 3rd line something like "xxxxx Bytes free" what is the "xxxxx"-number?

I don't have this information. The MSX boots directly on Sony Firmware. The pic I posted on my previous post.

By NYYRIKKI

Enlighted (5045)

NYYRIKKI's picture

21-02-2018, 03:24

Dr.Wily wrote:

I don't have this information. The MSX boots directly on Sony Firmware.

Try by holding DEL-key down at startup.

Page 1/4
| 2 | 3 | 4
My MSX profile