Sony HB-F1XD Floppy Issue

By jdgabbard

Resident (44)

jdgabbard's picture

01-02-2022, 17:54

I’m looking for ideas on troubleshooting a floppy drive in this machine. The drive does spin up, but the head doesn’t appear to move. Resulting in the message asking to abort or retry. I have disassembled the machine, and attempted connecting a known working FDD. The drive does spin up, and the head sounds like it might be working, but I still get the same error that it is not ready, and asks to abort or retry.

I’m thinking this could be an issue with the Sony machine only providing 5v, and not the 12v rail. But I wanted to get some input before I go any further with it.

Any suggestions?

Login or register to post comments

By sdsnatcher73

Enlighted (4299)

sdsnatcher73's picture

01-02-2022, 18:31

About that known working drive, is it a PC drive? Modified for MSX? Ready signal on pin 34?

Without the ready signal on pin 34 a drive that may work in e.g. a Philips MSX will not work in a Sony MSX. In such case your drive needs some more modification. If the drive already has ready signal on pin 34 it seems something else is wrong. The modified drive won’t need 12V so it us unlikely that is the cause. But first step is to identify what kind of drive you are testing with.

By jdgabbard

Resident (44)

jdgabbard's picture

02-02-2022, 00:05

It is in fact a PC drive. Pin 34 is present, but I’m not sure what signal is present on it. Not sure what modifications might be required.

By Wierzbowsky

Guardian (3649)

Wierzbowsky's picture

02-02-2022, 04:57

Try to recap the drive - this helps in many cases. Replace all electrolytes with ceramics. Also, measure the resistance on the wires going to both heads (each head has 4 wires) with a multimeter. If you have some reading (tens of ohms), then the heads are alive. Sony's drives are pain in the @ss to fix, but it's still better to fix the original one rather than trying to find a working replacement.

So far, I succeeded replacing the dead drives in Sonys with Samsung SDF-321 that has to be modded (very easy!). The only sucky point is to properly bend the eject button's holder and trim the button (remove central rib).

By jdgabbard

Resident (44)

jdgabbard's picture

02-02-2022, 03:18

Alexey, thanks for the advice. I'll take a look at this, and see what I find. This seems like it could be a better solution than trying to modify a PC FDD to work. I've taken a look at several I have on had. They all appear to use very similar control boards. They do have SMD jumpers for DS0 and DS1, but I'm not seeing anything indicative of the Ready signal. So that said, it may be a fruitless chore to try modifying one.