Sony XV-T550 demystified. Look here if you have one.

Page 6/6
1 | 2 | 3 | 4 | 5 |

By Piter Punk

Master (224)

Piter Punk's picture

13-05-2019, 23:21

lintweaker wrote:

I'll have to revisit. I will start adding beeps to see how far it goes.
I did some tests with the joystick port trick, never got a picture

Your titler is the XV-T550? I have an XV-J550 and neither the mouse port trick or the modified ROM works.

I still need to dump the XV-J550 ROM to find a good place to call in slot 3-1.

By NYYRIKKI

Enlighted (5889)

NYYRIKKI's picture

13-05-2019, 23:58

Piter Punk wrote:

I have an XV-J550 and neither the mouse port trick or the modified ROM works.

I still need to dump the XV-J550 ROM to find a good place to call in slot 3-1.

Hmm... but does it anyway boot from the cartridge slot normally?

If it does, then you can get the ROMs if you just do AUTOEXEC.BAT with something like:
SAVEROM XVJ550.ROM < ANSWERS.TXT

By Manuel

Ascended (18256)

Manuel's picture

13-05-2019, 23:57

NYYRIKKI wrote:
Manuel wrote:

I tried to run it in openMSX with the Konami mapper, but it crashes at startup, showing the green background screen.

Removing disk drive should fix this.

Ah, indeed, on a Philips NMS 8220 it boots and tries to show the 'connect the keyboard' message. Do you know how it's trying to detect that keyboard?

NYYRIKKI wrote:
Quote:

Did you try with the dynamic patcher?

No... It seems that I've lost my original 1024KB work dump of the memory. Sad I tried to look for it, but I have no idea where it has went... I guess I have to ask you to send me a copy or dump it again some day.

I don't have it either... and I didn't put any effort to run my XV-T550 as MSX (sorry, no time for that for now), but perhaps lintweaker can help there.

By NYYRIKKI

Enlighted (5889)

NYYRIKKI's picture

14-05-2019, 01:10

Manuel wrote:

Do you know how it's trying to detect that keyboard?

No, not really, but I took a quick look...

I think it might be this check where bit0 of I/O #70 is reset and low nibble of #71 is checked that it is #E and then bit0 of I/O #70 is set and low nibble of #71 is checked that it is #7

By lintweaker

Champion (417)

lintweaker's picture

14-05-2019, 17:47

Piter Punk wrote:

Your titler is the XV-T550? I have an XV-J550 and neither the mouse port trick or the modified ROM works.

I still need to dump the XV-J550 ROM to find a good place to call in slot 3-1.

Yes, I do have the 'T' version. Is does startup normal cartridges just fine (judging from the game sounds)

By zett

Hero (608)

zett's picture

14-05-2019, 19:18

gona sell mine

By hamlet

Scribe (3743)

hamlet's picture

14-05-2019, 21:46

Don't do this! Maybe you want to set another title and then you regret it!

By NYYRIKKI

Enlighted (5889)

NYYRIKKI's picture

15-07-2019, 08:03

NYYRIKKI wrote:
Manuel wrote:

That dump is only 64kB... how does this match with 128 pages of 8kB?

Well, that was not accurate explanation, that was a "shortcut"... but indeed if the ROM was only 64KB then there is now one bit that does not match the documentation...

Let's see what I wrote:

Quote:

bit 7: 1 = Enable SRAM & Video output *
bit 6: ROM select. 0=Program ROM 1=FONT ROM
bit 5: FONT ROM: hi bit of mapper page. Program ROM: 1=disable memory (#FF)
bit 4: mapper page (not used by program ROM)
bits 0-3 mapper page

If we translate this to 128 page size 8K mapper this means that
Pages 0-15 = Program ROM (16*8K = 128K !!! ...weird) and pages 64-127 are Font ROM (64*8K = 512KB)

Maybe the program ROM was mirrored 4 times (Pages 0-7, 8-15, 16-23 and 24-31) instead of 2 times (Pages 0-15, 16-31)
I don't remember anymore and seems that I have no idea where my original dumps are ATM... I anyway remember that pages 32-63 were empty.

Ok, as I had lost the dump, I did it again to confirm and the original explanation seems to be accurate...
Converting the description to 8kB pages means...

- Pages 0-9 seem to have program content... pages 10-15 are empty.
- Pages 0-15 mirror on pages 16-31... pages 32-63 are empty
- Pages 64-119 contain the font files... pages 120-127 are empty

By popolon_

Master (189)

popolon_'s picture

15-03-2021, 12:44

Has somebody managed to get XV-J550 to output proper screen and startup?

I dumped some content from this unit:
https://github.com/popolonx/MSX_STUFF/blob/main/XV-J550/BIOS...
And then got modified binary from NYYRIKKI, and that binary is now at the:
https://github.com/popolonx/MSX_STUFF/blob/main/XV-J550/XV-X...
The binary was flashed to megaflashrom:
OPFXSD X550MFR.ROM /I1
And some output is get, but no game is actually started and no basic screen is seen:
start screen2
At least with basic it stays at that screen.
One can hear one beep during this startup.

With game (for example boulder dash and aleste) loaded, it reboots continuously, showing this screen also:
reboot

With these same games and this "firmware" in megaflashrom, in Philips 8245, there is two reboots, and then the game starts. Any idea how to debug this further?

And by the way, has somebody added full keyboard to this machine, as there is marked pins in PCB for X0-X7 and Ya,Yb,Yc,Yd ?

Page 6/6
1 | 2 | 3 | 4 | 5 |