Sunrise IDE CF installation

Page 2/3
1 | | 3

By msd

Paragon (1458)

msd's picture

03-05-2004, 23:35

dos2.41 doesn't take more tpa. I've hone some test with this because I had tpa problems. I tried different combination and found out it was the msxdos2.sys ver 2.31 that uses more tpa. I now use sys version 2.20 and command2.com version 2.41. There is even more tpa free then with command 2.com version 2.20.

By dhau

Paragon (1570)

dhau's picture

07-05-2004, 18:34

If you boot with IDE, you should have floppy on C: (if you made 2 partitions). Copy MSXDOS2 from this floppy to drive A: (in basic) and reset...

Please tell me how to copy files from C: to A: in MSX Basic?

Thank you!

By [D-Tail]

Ascended (8246)

[D-Tail]'s picture

07-05-2004, 18:44

copy "C:*.*" to "A:"

You might wanna add a backslash (or Yen sign, in case of a Japanese MSX), so it becomes this:

copy "C:\*.*" to "A:\".

Difference between them is this:
'd:\' points to the root directory (base directory, the uppermost in a directory tree) of the specified drive 'd'.
'd:' points to the current directory on drive denoted by 'd'. So for example, you were in MSX-DOS2.

MSX-DOS 2.30 Copyright by ASCII (or something like this)

A:\>

type 'cd utils'.

A:\UTILS>

type 'C:'.

C:\>

type BASIC.

C:\>BASIC

You're in BASIC now. If you blindly say 'copy "c:*.*" to "a:"', all files in 'C:\' are copied to 'A:\UTILS'.

Ow, and please don't use IDEFDISK.COM. Use FDISK310 instead. Note that your IDE BIOS must be up to date, for Flash cards to work.

By dhau

Paragon (1570)

dhau's picture

07-05-2004, 20:07

Thank you very much! I knew about this long time ago (1990), but completely forgot Sad

By galine

Rookie (25)

galine's picture

28-09-2010, 15:31

Hello,

I have a strange probleme with my hard drive I loose my boot partition after launch game I don't now exactely witch I think final fantasy but I'm not realy sure. but now I can't run hard drive without dos 2 floppy disk.

I would like know if it's possible to format only one partition the A: for me without kill the all others? caus I looking inside my others partition and all semms good.

in my Msx

-nms8255 2+
-turbo 7mhz
-4 mo memory
-Interface ide sunrise with hard drive and CF card
-pc floppy disk
-HXC sd

-Dos 2.20
-Fat 12 (boot partition)
-4x Fat 16 (other partition on hard drive)
-1x Fat 16 (cf card)

Please if you know what I must make for repare that let me know.

Thank you in advance galine.

By Bastiaan

Champion (333)

Bastiaan's picture

28-09-2010, 15:59

can you read your boot partition if you boot with dos2 floppy?

By protek

Expert (96)

protek's picture

28-09-2010, 16:19

copy "C:*.*" to "A:"

You might wanna add a backslash (or Yen sign, in case of a Japanese MSX), so it becomes this:

copy "C:\*.*" to "A:\".


Slightly off topic but does MSX-DOS require the quotation marks and the 'to' attribute in the copy command or can you just simply write'copy C:\*.* A:\' as in MS-DOS?

By galine

Rookie (25)

galine's picture

28-09-2010, 18:40

No I can read first partiton it semms broken when I try to copy dos in partition I have that :

"Disk I/O error like when I try to read fat 16 without patch.

By Manuel

Ascended (17876)

Manuel's picture

28-09-2010, 19:01

Heh, I've had this problem as well, a few times, on my SCSI system... very annoying.

I don't remember how I solved it back then. I think that if you make a backup first, you can start experimenting.

First experiment: overwrite the partition table with exactly the same data and see if things are better. Do this on your copy of course.

By galine

Rookie (25)

galine's picture

28-09-2010, 19:12

I have already to make that but I haven't make cause I will make a backup of my fat 16 partition before (I think it will take me a little time cause windows realy hate copy small folders ^^. but I think it's the best way for that.

I must found what broke my fat 12 partition cause I wouldn't broke it again. I suspect a final fantasy disk image is the cause of my probleme all beguin at this moment. I know somes sony software destruct hard drive boot sector.

Page 2/3
1 | | 3