SX-1+ Mini with MegaFlashRom SCC+ SD problem(s)

Page 6/6
1 | 2 | 3 | 4 | 5 |

By tooloud

Rookie (20)

tooloud's picture

22-11-2020, 02:06

@SkalTura, my Megaflashrom SCC+ SD works fine in 1st slot (top) of SX1mini+. I have disabled internal microsd slot and summing - I'm using set to on just on #2-#3 dipswitches (the rest is set to off). I do not have this SX-1mini for more then a few days, but - as for now - all works as expected. If any to test and compare - just ask me.

By SkalTura

Master (247)

SkalTura's picture

23-11-2020, 14:42

@tooloud, I also have only dipswitches 2 and 3 to on and the rest off, and MFR inserted in the top slot.
But mine (or at least, the combination) is very unstable...

By SkalTura

Master (247)

SkalTura's picture

03-12-2020, 15:11

Okay, new update...

Found a few more dodgy soldering, so ended up re-soldering every single components and chip pin by hand.
Sadly, still the same issues.

Then I replaced the pull-up resistors array for the 10k version.
A bit more stable, but still fails.

Added a larger capacitors over the 5V power regulator.
Again a bit more stable, but still fails.

However...
Ice-cold start (meaning having the power completely off for more than a minute), makes the MFR startup normally every single time now.
Shorter cold starts, or warm starts (reset button), still fails.

So, we have some improvement...!
Still find it strange that the problem only seems to happen with the MFR and not with other cartridges...

By KdL

Paragon (1350)

KdL's picture

03-12-2020, 15:28

I have a very recent discovery to report to you. The SX-1 and SX-1 Mini+ external slots appear to have a slight nominal voltage deficit due to the length of the power cable. So I also recommend that you test a power supply with a 50cm cable.

By SkalTura

Master (247)

SkalTura's picture

03-12-2020, 16:17

KdL wrote:

So I also recommend that you test a power supply with a 50cm cable.

That was one of the first things I tried when testing with different cables and power supplies.
Cable I ended up using is only 30cm's long, and thick wire (0.75mm²).
So that's not the issue I think.

What I could try is to solder a capacitor (for example 100μF) directly over the power pins of the cartridge slot...?

By KdL

Paragon (1350)

KdL's picture

03-12-2020, 20:21

I think you should try the MFR on another OCM machine like Zemmix Neo to see if the problem persists. Making random changes to the SX-1 Mini+ may compromise the use of other cartridges.

10K pull ups are wrong, for example the Goonies "R" Good Enough cartridge and others may not work with those pull ups.

>>What I could try is to solder a capacitor (for example 100μF) directly over the power pins of the cartridge slot...?
I don't have a cartridge like yours to test, so I don't know. I only have an old MFR first version without SD card.

Page 6/6
1 | 2 | 3 | 4 | 5 |